summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-01-20 11:47:07 +0100
committerhaawda2019-01-20 11:47:07 +0100
commit55d61122177ee3c290f6fa83824b1349c1bec38b (patch)
tree5ddccdf85b329ef84862c7ff9bbedfec86ace898
parente7d8f393ad348062d2cc5837f5ffa1f7ddf11096 (diff)
downloadaur-55d61122177ee3c290f6fa83824b1349c1bec38b.tar.gz
rewrite
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a9ed5abcf58..efec27ad2919 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = textext-git
pkgdesc = An inkscape extension which lets you add LaTeX equations to your drawings
- pkgver = 0.8.1.1.g0164a57
+ pkgver = 0.9.0.8.g0a4b388
pkgrel = 1
epoch = 1
- url = https://bitbucket.org/pitgarbe/textext
+ url = https://github.com/textext/textext.git
arch = any
license = custom:BSD
makedepends = mercurial
@@ -18,7 +18,7 @@ pkgbase = textext-git
optdepends = imagemagick6
provides = textext
conflicts = textext
- source = textext::git+https://github.com/textext/textext.git
+ source = git+https://github.com/textext/textext.git
md5sums = SKIP
pkgname = textext-git
diff --git a/PKGBUILD b/PKGBUILD
index 29d919c7da49..2e825941cefd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,37 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=textext-git
-pkgver=0.8.1.1.g0164a57
+pkgver=0.9.0.8.g0a4b388
epoch=1
pkgrel=1
pkgdesc="An inkscape extension which lets you add LaTeX equations to your drawings"
arch=('any')
license=('custom:BSD')
-url="https://bitbucket.org/pitgarbe/textext"
+url="https://github.com/textext/textext.git"
provides=('textext')
conflicts=('textext')
makedepends=('mercurial')
depends=('inkscape' 'python2' 'texlive-core')
optdepends=('pygtk' 'python2-lxml' 'pdf2svg' 'pstoedit' 'ghostscript' 'imagemagick6')
-source=("textext::git+https://github.com/textext/textext.git")
+source=("git+$url")
md5sums=('SKIP')
-prepare() {
- cd textext/
- sed -i '1s|python\>|python2|' *.py
-}
-
pkgver() {
- cd textext
+ cd ${pkgname%-git}
git describe --tags |tr - .
}
package() {
- cd textext/
install -d "$pkgdir"/usr/share/inkscape/extensions
- for _i in asktext.py default_packages.tex latexlogparser.py textext.{inx,py} typesetter.py win_app_paths.py
- do install ${_i} "$pkgdir"/usr/share/inkscape/extensions/$_i
- done
+ cd ${pkgname%-git}/extension
+ cp -r ${pkgname%-git} "$pkgdir"/usr/share/inkscape/extensions
+ install -m644 ${pkgname%-git}.inx "$pkgdir"/usr/share/inkscape/extensions/
+ cd ..
install -d "$pkgdir"/usr/share/licenses/$pkgname
install LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ cd "$pkgdir"/usr/share/inkscape/extensions/${pkgname%-git}
+ sed -i '1s+\#!/usr/bin/env python+\#!/usr/bin/env python2+' __init__.py typesetter.py
}
+