summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRay Shirohara2021-05-18 22:27:43 +0900
committerRay Shirohara2021-05-18 22:38:04 +0900
commitac792dc23f017fa970012f50ee4a8402b917ced6 (patch)
treeecbc4c76de53b73760320c7a888c4569126354c8
parent615a66c360a9bdd93765796fd52eb585d263c9a6 (diff)
downloadaur-ac792dc23f017fa970012f50ee4a8402b917ced6.tar.gz
build: add build option
- Add build option "buildmode=pie" and "trimpath". - Add docs. - Add dependency "glibc".
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e80ae3a319e..006166f7c252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = textimg
pkgdesc = Command to convert from color text (ANSI or 256) to image.
pkgver = 3.0.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jiro4989/textimg
arch = x86_64
license = MIT
makedepends = go
+ depends = glibc
provides = textimg
options = !strip
source = https://github.com/jiro4989/textimg/archive/v3.0.6.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c4ffd82f8f3c..5bf92fcbe109 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=textimg
pkgver=3.0.6
-pkgrel=2
+pkgrel=3
pkgdesc='Command to convert from color text (ANSI or 256) to image.'
arch=('x86_64')
url='https://github.com/jiro4989/textimg'
license=('MIT')
+depends=('glibc')
makedepends=('go')
provides=('textimg')
options=('!strip')
@@ -15,7 +16,7 @@ sha256sums=('ab7ad2965a826cc576ba23f3e75e0e973e0bfcd675a6183d674badb17ba6812c')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- go build
+ go build -buildmode=pie --trimpath
}
check() {
@@ -27,4 +28,8 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 README_ja.md "${pkgdir}/usr/share/doc/${pkgname}/README_ja.md"
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/img"
+ install -Dm644 img/* "${pkgdir}/usr/share/doc/${pkgname}/img/"
}