summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArjun Nemani2018-07-09 10:20:42 +0530
committerArjun Nemani2018-07-09 10:20:42 +0530
commitef8337b99eabd1ffddce2861af6c10df587160ae (patch)
treee73e10e8c7568788f20df73437e0407a0c716790
downloadaur-ef8337b99eabd1ffddce2861af6c10df587160ae.tar.gz
Add npm textlint-plugin-review to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39965f668449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textlint-plugin-review
+ pkgdesc = textlint Re:VIEW processsor plugin.
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/orangain/textlint-plugin-review
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = textlint-plugin-review-0.3.3.tgz
+ source = http://registry.npmjs.org/textlint-plugin-review/-/textlint-plugin-review-0.3.3.tgz
+ sha1sums = 7575aeb562fcdf7597e14f55230b805cec735eb8
+
+pkgname = textlint-plugin-review
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b26ea135947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=textlint-plugin-review
+_npmver=0.3.3
+pkgname=textlint-plugin-review # All lowercase
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="textlint Re:VIEW processsor plugin."
+arch=(any)
+url="https://github.com/orangain/textlint-plugin-review"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(7575aeb562fcdf7597e14f55230b805cec735eb8)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: