summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-07-31 20:54:06 +0300
committerIgor Dyatlov2021-07-31 20:54:06 +0300
commit4c3033bebfbe9802df05619053b73b7d71c334ed (patch)
tree8125269983c06352631a96cffcf81715f89522a8
downloadaur-4c3033bebfbe9802df05619053b73b7d71c334ed.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c872b598c068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = textpieces-git
+ pkgdesc = Small tool for quick text transformations such as hashes, encoding, decoding and so on
+ pkgver = 1.3.1.r95.g373a43d
+ pkgrel = 1
+ url = https://github.com/liferooter/textpieces
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = vala
+ depends = gtk4
+ depends = json-glib
+ depends = libadwaita
+ depends = python-pyaml
+ depends = gtksourceview4
+ depends = libhandy
+ depends = python
+ depends = python-gobject
+ provides = textpieces
+ conflicts = textpieces
+ source = git+https://github.com/liferooter/textpieces.git
+ b2sums = SKIP
+
+pkgname = textpieces-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da2dc21bd71b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=textpieces-git
+_pkgname=textpieces
+pkgver=1.3.1.r95.g373a43d
+pkgrel=1
+pkgdesc="Small tool for quick text transformations such as hashes, encoding, decoding and so on"
+arch=('x86_64')
+url="https://github.com/liferooter/textpieces"
+license=('GPL3')
+depends=('gtk4' 'json-glib' 'libadwaita' 'python-pyaml' 'gtksourceview4' 'libhandy' 'python' 'python-gobject')
+makedepends=('git' 'gobject-introspection' 'meson' 'vala')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+} \ No newline at end of file