summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAniket Pradhan2019-04-18 13:53:12 +0530
committerAniket Pradhan2019-04-18 13:53:12 +0530
commit0ccdf031c4c4a41933773e94ffb1b9ac36443cc6 (patch)
tree2533a33196ac3cb642743e359dc134090ad3afdf
parent97ddb6a55d984354096a7d60c3ce8023d2cd0dbf (diff)
downloadaur-0ccdf031c4c4a41933773e94ffb1b9ac36443cc6.tar.gz
Fixed package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f700babffd5..e7ade6ad7e10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,9 +4,7 @@ pkgbase = textql-git
pkgrel = 1
url = https://github.com/dinedal/textql
arch = x86_64
- arch = i686
license = MIT
- makedepends = dep
depends = go-pie
options = !strip
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index b94dd78114b6..32044616fac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,34 +5,34 @@ pkgname=textql-git
pkgver=2.0.3
pkgrel=1
pkgdesc="Execute SQL against structured text like CSV or TSV"
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="https://github.com/dinedal/textql"
license=('MIT')
depends=('go-pie')
-makedepends=('dep')
options=('!strip' '!emptydirs')
-source=("textql-git::git+https://github.com/dinedal/textql")
+source=("$pkgname::git+https://github.com/dinedal/textql")
prepare(){
mkdir -p gopath/src/github.com
ln -rTsf $pkgname $srcdir/gopath/src/github.com/$pkgname
export GOPATH="$srcdir"/gopath
cd $GOPATH/src/github.com/$pkgname
- dep ensure
+ go get -d ./...
}
build(){
- export GOPATH=$srcdir/gopath
- cd gopath/src/github.com/$pkgname
- go install \
- -gcflags "all=-trimpath=$GOPATH" \
- -asmflags "all=-trimpath=$GOPATH" \
- -ldflags "-extldflags $LDFLAGS" \
- -v ./...
+ export GOPATH="$srcdir"/gopath
+ cd $GOPATH/src/github.com/$pkgname
+ go build textql/main.go
+ #-gcflags "all=-trimpath=$GOPATH" \
+ #-asmflags "all=-trimpath=$GOPATH" \
+ #-ldflags "-extldflags $LDFLAGS" \
+ #-v ./...
}
package() {
- install -Dm755 gopath/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+ export GOPATH="$srcdir"/gopath
+ install -Dm755 "$GOPATH"/src/github.com/$pkgname/main "$pkgdir"/usr/bin/textql
for f in LICENSE COPYING LICENSE.* COPYING.*; do
if [ -e "$srcdir/src/$_gourl/$f" ]; then