summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 18:03:34 -0400
committergraysky2015-06-08 18:03:34 -0400
commit8f9df963be6bed25471de37c2b4035d2e391d406 (patch)
treed20610f57b03672409460032eb93de90e01d3024
downloadaur-8f9df963be6bed25471de37c2b4035d2e391d406.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--readme.install7
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce1e7f4a2f3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = texturecache
+ pkgdesc = Utility to manage the XBMC/Kodi texture cache and more.
+ pkgver = 1.9.4
+ pkgrel = 1
+ url = https://github.com/MilhouseVH/texturecache.py
+ install = readme.install
+ arch = any
+ license = GPL
+ depends = python
+ depends = kodi
+ conflicts = xbmc-texturecache
+ replaces = xbmc-texturecache
+ source = https://github.com/MilhouseVH/texturecache.py/archive/1.9.4.tar.gz
+ sha256sums = 13ec361d76de07996dfb5bdd16282eb36e6b2e8ae05e5e1fe928bd58b2e62f8d
+
+pkgname = texturecache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ce3d3e02b07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=texturecache
+_pkgname=texturecache.py
+pkgver=1.9.4
+pkgrel=1
+pkgdesc="Utility to manage the XBMC/Kodi texture cache and more."
+arch=('any')
+url="https://github.com/MilhouseVH/texturecache.py"
+license=('GPL')
+depends=('python' 'kodi')
+conflicts=('xbmc-texturecache')
+replaces=('xbmc-texturecache')
+install=readme.install
+source=("https://github.com/MilhouseVH/${_pkgname/%%.py}/archive/$pkgver.tar.gz")
+sha256sums=('13ec361d76de07996dfb5bdd16282eb36e6b2e8ae05e5e1fe928bd58b2e62f8d')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/texturecache"
+ install -Dm644 "texturecache.cfg.defaults" "$pkgdir/usr/share/texturecache/texturecache.cfg"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..0ebb470b223f
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,7 @@
+post_install() {
+cat << 'EOM'
+==> The xbmc/kodi webserver must be enabled and running on port 8080.
+==> Optionally copy /usr/share/texturecache/texturecache.cfg to ~/.config
+==> and uncomment options therein for additional flexibility.
+EOM
+}