summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Richards2018-07-16 23:17:05 -0400
committerTom Richards2018-07-16 23:17:05 -0400
commit94797ad4edd6f6c4732a9fa13747b22940ec33eb (patch)
treefb00411040d7ed2ed273f9171468e29a01f9dca5
parente484ffdb46c40175b78ef66996b3c231a06d5e5f (diff)
downloadaur-94797ad4edd6f6c4732a9fa13747b22940ec33eb.tar.gz
Patch synctex build issue, add icons
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD17
-rw-r--r--README.md18
4 files changed, 17 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f9339295a6c..b8ab06cc5219 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Aug 21 12:47:01 UTC 2017
pkgbase = texworks
pkgdesc = A TeX IDE inspired by TeXShop.
pkgver = 0.6.2
- pkgrel = 3
+ pkgrel = 4
url = https://www.tug.org/texworks/
arch = i686
arch = x86_64
@@ -13,6 +11,7 @@ pkgbase = texworks
makedepends = python
makedepends = qt5-tools
depends = desktop-file-utils
+ depends = gtk-update-icon-cache
depends = hunspell
depends = poppler-qt5
depends = qt5-script
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 7e11b2109176..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-The MIT License (MIT)
-
-Copyright (c) 2015 Tom Richards
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 1ee2ee4d9dcd..82953d0b8c1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=texworks
pkgver=0.6.2
-pkgrel=3
+pkgrel=4
pkgdesc='A TeX IDE inspired by TeXShop.'
arch=('i686' 'x86_64')
url='https://www.tug.org/texworks/'
license=('GPL2')
-depends=('desktop-file-utils' 'hunspell' 'poppler-qt5' 'qt5-script')
+depends=('desktop-file-utils' 'gtk-update-icon-cache' 'hunspell' 'poppler-qt5' 'qt5-script')
optdepends=('texlive-core: Support for typesetting'
'lua: Support for Lua scripting/plugins'
'python: Support for Python scripting/plugins')
@@ -20,6 +20,11 @@ conflicts=('texworks-svn')
source=("https://github.com/TeXworks/${pkgname}/archive/release-${pkgver}.tar.gz")
sha256sums=('22885c11d92654b0cba1f4808fc9aa3c2fdd3e5435fd89dff9aa1e67658a6339')
+prepare() {
+ cd "$pkgname-release-$pkgver"
+ sed -i 's/synctex_next_result/synctex_scanner_next_result/g' src/*.*
+}
+
build() {
cd "$pkgname-release-$pkgver"
cmake \
@@ -34,4 +39,12 @@ build() {
package() {
cd "$pkgname-release-$pkgver"
make install
+
+ for size in 48 128; do
+ install -Dm644 res/images/TeXworks-doc-${size}.png \
+ "${pkgdir}"/usr/share/icons/hicolor/${size}x${size}/mimetypes/text-x-tex.png
+ done
+
+ install -Dm644 res/images/TeXworks-128.png \
+ "${pkgdir}"/usr/share/icons/hicolor/128x128/apps/texworks.png
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 6eea5e669e9c..000000000000
--- a/README.md
+++ /dev/null
@@ -1,18 +0,0 @@
-# Introduction
-
-This is the [PKGBUILD][pkgbuild] and related source files to build
-[TeXworks](texworks) on [Arch Linux](archlinux).
-
-# Instructions
-
-What, you wanted step-by-step install instructions? [This package][this-package]
-is available from the [AUR][aur]. You can install it by using the official
-method for installing unsupported packages, which is exhaustively described in
-the [Arch User Repository][aur-wiki] wiki article.
-
-[archlinux]: https://www.archlinux.org
-[aur-wiki]: https://wiki.archlinux.org/index.php/Arch_User_Repository
-[aur]: https://aur.archlinux.org/
-[pkgbuild]: https://wiki.archlinux.org/index.php/PKGBUILD
-[texworks]: http://www.tug.org/texworks/
-[this-package]: https://aur.archlinux.org/packages/texworks/