diff options
author | zxp19821005 | 2024-08-29 18:40:06 +0800 |
---|---|---|
committer | zxp19821005 | 2024-08-29 18:40:06 +0800 |
commit | ea6cd9f9efc7d2c7a1c93faab3916bf806e9af57 (patch) | |
tree | dd2c519721a33ac0e2efd40dd30f321bcb4d84a9 | |
parent | 854ab0117ada049732cda7a7cef881fbb02102bb (diff) | |
download | aur-ea6cd9f9efc7d2c7a1c93faab3916bf806e9af57.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 7 | ||||
-rw-r--r-- | tfiletransfer.sh | 6 |
3 files changed, 9 insertions, 8 deletions
@@ -1,7 +1,7 @@ pkgbase = tfiletransfer-bin pkgdesc = File transfer tools built with Compose for Desktop. It could send/receive files to/from other devices via LocalNetwork. pkgver = 2.2.1 - pkgrel = 6 + pkgrel = 7 url = https://github.com/Tans5/tFileTransfer_desktop arch = x86_64 license = Apache-2.0 @@ -14,6 +14,6 @@ pkgbase = tfiletransfer-bin source = tfiletransfer-2.2.1.deb::https://github.com/Tans5/tFileTransfer_desktop/releases/download/v2.2.1/tfiletransfer_2.2.1_amd64.deb source = tfiletransfer.sh sha256sums = 949d4f774f79f03ed44bdca7cf3d6a8bee3d8c1a096e367f2dfc4161dca8d3cd - sha256sums = 386f823e2cb5e962ca22010f63a0681cc059c6d77b236fb2650f0694010c0867 + sha256sums = 8412755a233bf7404a723fd6458c6a5c32a4456addfeb5c9a96600e6556aeda8 pkgname = tfiletransfer-bin @@ -2,7 +2,7 @@ pkgname=tfiletransfer-bin _pkgname=tFileTransfer pkgver=2.2.1 -pkgrel=6 +pkgrel=7 pkgdesc="File transfer tools built with Compose for Desktop. It could send/receive files to/from other devices via LocalNetwork." arch=('x86_64') url="https://github.com/Tans5/tFileTransfer_desktop" @@ -20,7 +20,7 @@ source=( "${pkgname%-bin}.sh" ) sha256sums=('949d4f774f79f03ed44bdca7cf3d6a8bee3d8c1a096e367f2dfc4161dca8d3cd' - '386f823e2cb5e962ca22010f63a0681cc059c6d77b236fb2650f0694010c0867') + '8412755a233bf7404a723fd6458c6a5c32a4456addfeb5c9a96600e6556aeda8') build() { sed -e "s|@appname@|${pkgname%-bin}|g" \ -e "s|@runname@|${_pkgname}|g" \ @@ -32,7 +32,8 @@ build() { } package() { install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}" - cp -r "${srcdir}/opt" "${pkgdir}" + install -Dm755 -d "${pkgdir}/usr/lib" + cp -r "${srcdir}/opt/${pkgname%-bin}" "${pkgdir}/usr/lib" install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png" install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop" }
\ No newline at end of file diff --git a/tfiletransfer.sh b/tfiletransfer.sh index 57edd8b5689a..8e729c262ced 100644 --- a/tfiletransfer.sh +++ b/tfiletransfer.sh @@ -1,6 +1,6 @@ -#!/bin/sh -set -e -_APPDIR=/opt/@appname@ +#!/bin/bash +set -o pipefail +_APPDIR=/usr/lib/@appname@ _RUNNAME="${_APPDIR}/bin/@runname@" export PATH="${_APPDIR}:${_APPDIR}/bin:${PATH}" export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}" |