summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2023-01-09 19:55:27 +0000
committerJonathan Wright2023-01-09 19:55:27 +0000
commit2b031e1b7516d1cc5716bea1776f96dd1d3a9a61 (patch)
tree9b8bf51cac100bb6bf4b05e523d739152b082b40
parenta167bac6f401ec18a4e780b08444bdfe95e30ddd (diff)
downloadaur-2b031e1b7516d1cc5716bea1776f96dd1d3a9a61.tar.gz
Sync Makefile changes
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 3721b908155b..a8e5348c6bdc 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,7 @@ ifdef ($(string $(pkgrel)),)
use_pkgrel=$(pkgrel)
else
ifeq ($(pkgver),$(current_pkgver))
- use_pkgrel=$(current_pkgrel)+1
+ use_pkgrel=$(shell expr $(current_pkgrel) + 1)
else
use_pkgrel=1
endif
@@ -36,7 +36,7 @@ help: ## Show this help message
.PHONY: clean
clean: ## Clean the current workspace
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old package files${CC_END}"
- rm -f *.pkg.tar.{xz,zst} *.zip{,.part}
+ rm -rf *.pkg.tar.{xz,zst} *.{zip,gz,xz,zst}{,.part}
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old working directories${CC_END}"
rm -rf ./pkg ./src