summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoan Blanc2021-03-17 07:36:31 +0100
committerYoan Blanc2021-03-17 07:36:31 +0100
commit37225c281ad3d8b42c431bfb36aa27b4ef740e7f (patch)
tree76960dd5db012a75e960638a0110410cfcc32d89
parent2858d989024c091e261e880913c8e444fff11bee (diff)
downloadaur-37225c281ad3d8b42c431bfb36aa27b4ef740e7f.tar.gz
feat: install LICENSE
Signed-off-by: Yoan Blanc <yoan@dosimple.ch>
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f44d2cbdb9f9..771d7b21c6da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = tfsec
pkgdesc = Static analysis powered security scanner for your terraform code
pkgver = 0.39.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tfsec/tfsec
arch = x86_64
license = MIT
depends = glibc
source = https://github.com/tfsec/tfsec/releases/download/v0.39.8/tfsec-linux-amd64
+ source = https://raw.githubusercontent.com/tfsec/tfsec/v0.39.8/LICENSE
sha256sums = d58cb71410a5510e7a3808108d1844c7968c1f017a5f33846c1d3fbd92409600
+ sha256sums = d59c7e06f84530a8464a352e7b7e153830d566e06aa8ca6a72defa809fad3a37
pkgname = tfsec
diff --git a/.gitignore b/.gitignore
index 85994b74b61b..bdb725275a35 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
*xz
*gz
*tar
+*zst
pkg/
src/
tfsec-linux-amd64
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 1b492d55c3df..4d2a09eae695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Mathias Merscher <archlinux@rheinekopfsache.de>
+# Maintainer: Yoan Blanc <yoan@dosimple.ch>
pkgname=tfsec
pkgver=0.39.8
-pkgrel=1
+pkgrel=2
pkgdesc="Static analysis powered security scanner for your terraform code"
depends=(glibc)
arch=(x86_64)
url="https://github.com/tfsec/tfsec"
license=('MIT')
-source=("https://github.com/tfsec/tfsec/releases/download/v$pkgver/tfsec-linux-amd64")
-sha256sums=('d58cb71410a5510e7a3808108d1844c7968c1f017a5f33846c1d3fbd92409600')
+source=("https://github.com/tfsec/tfsec/releases/download/v${pkgver}/tfsec-linux-amd64"
+ "https://raw.githubusercontent.com/tfsec/tfsec/v${pkgver}/LICENSE")
+
+sha256sums=('d58cb71410a5510e7a3808108d1844c7968c1f017a5f33846c1d3fbd92409600'
+ 'd59c7e06f84530a8464a352e7b7e153830d566e06aa8ca6a72defa809fad3a37')
package() {
- install -D -m755 $srcdir/tfsec-linux-amd64 $pkgdir/usr/bin/tfsec
+ install -D -m755 "${srcdir}/tfsec-linux-amd64" "${pkgdir}/usr/bin/tfsec"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}