summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDJ Lucas2016-01-23 12:49:19 -0600
committerDJ Lucas2016-01-23 12:49:19 -0600
commitd4c3fc8b11e407eabeea80c839093d9dd761ba8a (patch)
treef1a1baaaf10412d678f8727ab7b9de5025803ac8
downloadaur-d4c3fc8b11e407eabeea80c839093d9dd761ba8a.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--tftpgui.cfg11
-rw-r--r--tftpgui.desktop10
-rw-r--r--tftpgui.install17
-rw-r--r--tftpgui.sh12
6 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27b9e115b0b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 18:49:04 UTC 2016
+pkgbase = tftpgui
+ pkgdesc = A TFTP server intended to run as a user initiated program, rather than a service daemon.
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://code.google.com/p/tftpgui/
+ install = tftpgui.install
+ arch = any
+ license = GPL3
+ makedepends = imagemagick
+ depends = tk
+ depends = python>=3.2
+ depends = authbind
+ source = https://tftpgui.googlecode.com/files/tftpgui_3_1.tar
+ source = tftpgui.sh
+ source = tftpgui.cfg
+ source = tftpgui.desktop
+ sha256sums = 3f40ac6e6dffdbf0301f7627756e1adc54257b02be9540add3db621cee3c749a
+ sha256sums = a590050a511a985049758b064769bea53df03f79fad2e071f646a783bcfb7359
+ sha256sums = 4ad821c1d7b768b0303e48f5f747886fcf238ebcd99ca575b2c97b39989871e0
+ sha256sums = 13d76d75247af030877f62012f8f156ca237ab33e6e083d54fbc50dfae8d1a6f
+
+pkgname = tftpgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e02b058f5e4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: DJ Lucas <dj@linuxfromscratch.org>
+
+pkgname=tftpgui
+pkgver=3.1
+pkgrel=1
+pkgdesc="A TFTP server intended to run as a user initiated program, rather than a service daemon."
+arch=('any')
+url="https://code.google.com/p/tftpgui/"
+license=('GPL3')
+depends=('tk' 'python>=3.2' 'authbind')
+makedepends=('imagemagick')
+install=tftpgui.install
+source=("https://${pkgname}.googlecode.com/files/${pkgname}_3_1.tar"
+ "tftpgui.sh"
+ "tftpgui.cfg"
+ "tftpgui.desktop")
+
+package() {
+ cd ${srcdir}
+ _pymin=`python --version | cut -d " " -f 2 | sed 's@\..$@@'`
+ install -vdm755 ${pkgdir}/usr/lib/python${_pymin}/site-packages
+ cp -r ${pkgname} ${pkgdir}/usr/lib/python${_pymin}/site-packages
+ install -vdm755 ${pkgdir}/usr/bin
+ install -vm755 ${srcdir}/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
+ install -vdm755 ${pkgdir}/usr/share/applications
+ install -vm644 ${srcdir}/tftpgui.desktop ${pkgdir}/usr/share/applications
+ for size in 16 24 32 48 72 96 128 256
+ do
+ install -vdm755 ${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps
+ convert ${srcdir}/${pkgname}/TFTPicon.ico[3] -resize ${size}x${size} \
+ ${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/tftpgui.png
+ done
+ install -vdm755 ${pkgdir}/etc
+ install -vm644 ${srcdir}/tftpgui.cfg ${pkgdir}/etc/tftpgui.cfg
+}
+sha256sums=('3f40ac6e6dffdbf0301f7627756e1adc54257b02be9540add3db621cee3c749a'
+ 'a590050a511a985049758b064769bea53df03f79fad2e071f646a783bcfb7359'
+ '4ad821c1d7b768b0303e48f5f747886fcf238ebcd99ca575b2c97b39989871e0'
+ '13d76d75247af030877f62012f8f156ca237ab33e6e083d54fbc50dfae8d1a6f')
diff --git a/tftpgui.cfg b/tftpgui.cfg
new file mode 100644
index 000000000000..80b2d3fd8525
--- /dev/null
+++ b/tftpgui.cfg
@@ -0,0 +1,11 @@
+[Folders]
+tftprootfolder = ~/.tftpgui/tftproot
+logfolder = ~/.tftpgui/logs
+
+[IPsetup]
+anyclient = 1
+clientipaddress = 192.168.0.0
+clientmask = 16
+listenipaddress = 0.0.0.0
+listenport = 69
+
diff --git a/tftpgui.desktop b/tftpgui.desktop
new file mode 100644
index 000000000000..72bbaf925cad
--- /dev/null
+++ b/tftpgui.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=TFTPgui
+GenericName=TFTP Server
+Comment=Run TFTPgui
+Exec=tftpgui
+Icon=tftpgui
+Terminal=false
+Categories=System;
diff --git a/tftpgui.install b/tftpgui.install
new file mode 100644
index 000000000000..9165c407ace1
--- /dev/null
+++ b/tftpgui.install
@@ -0,0 +1,17 @@
+post_install() {
+ groupadd tftpusers
+ touch /etc/authbind/byport/69
+ chmod 775 /etc/authbind/byport/69
+ chown root:tftpusers /etc/authbind/byport/69
+ echo "Add any TFTPgui users to the tftpusers group."
+ echo "Users will need to login again to refresh group membership."
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm /etc/authbind/byport/69
+ groupdel tftpusers
+}
diff --git a/tftpgui.sh b/tftpgui.sh
new file mode 100644
index 000000000000..4368fd1a01db
--- /dev/null
+++ b/tftpgui.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+_pymin=`/usr/bin/python3 --version | cut -d " " -f 2 | sed 's@\..$@@'`
+
+if [ ! -d ~/.tftpgui ]
+then
+ install -vdm755 ~/.tftpgui/{logs,tftproot}
+ sed "s@~@$HOME@" /etc/tftpgui.cfg > ~/.tftpgui.cfg
+ chmod 644 ~/.tftpgui.cfg
+fi
+
+/usr/bin/authbind /usr/bin/python3 /usr/lib/python${_pymin}/site-packages/tftpgui/tftpgui.py