summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA Farzat2021-11-30 14:13:11 +0900
committerA Farzat2021-11-30 14:13:11 +0900
commit18da0325b7616a9a56db5073ef5bd486a02916a2 (patch)
tree5d23d5419308d12cf4b76d69c7aab5545f70fe24
downloadaur-18da0325b7616a9a56db5073ef5bd486a02916a2.tar.gz
Initialise repo
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c651dfd9f9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tg-archive
+ pkgdesc = is a tool for exporting Telegram group chats into static websites, preserving the chat history like mailing list archives.
+ pkgver = 0.3.10
+ pkgrel = 1
+ url = https://github.com/knadh/tg-archive
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = python
+ depends = python-cryptg
+ depends = python-feedgen
+ depends = python-jinja
+ depends = python-pillow
+ depends = python-yaml
+ depends = python-telethon
+ source = https://files.pythonhosted.org/packages/90/54/2f0c5ec169ebfe0ab1c68c2b960acac248ab8b6b9ed6614208d484bed5b6/tg-archive-0.3.10.tar.gz
+ source = LICENSE
+ md5sums = 7ce6b76affff116facc2bf50e90e0a0b
+ md5sums = 55ddbd8fbf51b6f84a56155a16cd0a66
+
+pkgname = tg-archive
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e3f5ea267047
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License
+
+Copyright (c) 2021, Kailash Nadh. https://nadh.in
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa1e4148ab14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: A Farzat <a@farzat.xyz>
+
+pkgname=tg-archive
+pkgver=0.3.10
+pkgrel=1
+pkgdesc='is a tool for exporting Telegram group chats into static websites, preserving the chat history like mailing list archives.'
+arch=(any)
+url=https://github.com/knadh/tg-archive
+license=('MIT')
+depends=(python python-cryptg python-feedgen python-jinja python-pillow python-yaml python-telethon)
+makedepends=(python-pip python-wheel)
+conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
+source=(
+ 'https://files.pythonhosted.org/packages/90/54/2f0c5ec169ebfe0ab1c68c2b960acac248ab8b6b9ed6614208d484bed5b6/tg-archive-0.3.10.tar.gz'
+ 'LICENSE'
+)
+md5sums=(
+ '7ce6b76affff116facc2bf50e90e0a0b'
+ '55ddbd8fbf51b6f84a56155a16cd0a66'
+)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --optimize=1 --root="$pkgdir" --skip-build
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}