summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Hausmann2019-12-21 21:45:50 +0100
committerLaura Hausmann2019-12-21 21:45:50 +0100
commit8522e83d8f320021a8ea8194b21cdbd5904015d1 (patch)
tree969de2275d593203d2eac15eeb67e3080ff18338
downloadaur-8522e83d8f320021a8ea8194b21cdbd5904015d1.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ecbbf70bd50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tgcli-git
+ pkgdesc = A Telegram console client based on tdlib.
+ pkgver = 0.2a.r0.g3a4cb9e
+ pkgrel = 1
+ url = https://gitlab.com/lhausmann/tgcli
+ arch = x86_64
+ license = MIT
+ makedepends = dotnet-sdk-bin
+ options = !strip
+ source = tgcli-git::git+https://gitlab.com/lhausmann/tgcli.git#branch=master
+ md5sums = SKIP
+
+pkgname = tgcli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ccf28975dd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Laura Hausmann <laura@hausmann.dev>
+pkgname='tgcli-git'
+pkgver=0.2a.r0.g3a4cb9e
+pkgrel=1
+pkgdesc='A Telegram console client based on tdlib.'
+arch=('x86_64')
+url="https://gitlab.com/lhausmann/tgcli"
+license=('MIT')
+makedepends=('dotnet-sdk-bin')
+install=
+changelog=
+options=('!strip')
+source=("https://github.com/erayerdin/$pkgname/archive/v$pkgver.tar.gz")
+source=("$pkgname"::'git+https://gitlab.com/lhausmann/tgcli.git#branch=master')
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ curl -Lo warp-packer https://github.com/dgiagio/warp/releases/download/v0.3.0/linux-x64.warp-packer && chmod +x warp-packer
+ dotnet publish -c Release -r linux-x64
+ ./warp-packer --arch linux-x64 --input_dir telegram/bin/Release/netcoreapp3.1/linux-x64/publish --exec telegram --output tgcli.linux.run
+ chmod +x tgcli.linux.run
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ cp tgcli.linux.run $pkgdir/usr/bin/tgcli
+}
+