summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiremoon7772017-01-21 09:40:56 +0300
committerFiremoon7772017-01-21 09:40:56 +0300
commitee313a893bce1794cfac40a94c3a433ad5b0f253 (patch)
tree3b031f266c2b9a99d7493e9214124e21633b5db1
downloadaur-ee313a893bce1794cfac40a94c3a433ad5b0f253.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d041a90e0fcd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 06:40:15 UTC 2017
+pkgbase = tgfs
+ pkgdesc = user-space filesystem for Telegram attachments
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Firemoon777/tgfs
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libconfig
+ depends = libevent
+ depends = jansson
+ depends = fuse2
+ provides = tgfs
+ conflicts = tgfs
+ source = tgfs::git+https://github.com/Firemoon777/tgfs
+ sha256sums = SKIP
+
+pkgname = tgfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01ff73365ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=tgfs
+pkgver=0.1
+pkgrel=1
+pkgdesc="user-space filesystem for Telegram attachments"
+arch=('i686' 'x86_64')
+url="https://github.com/Firemoon777/tgfs"
+license=('GPL3')
+depends=('libconfig' 'libevent' 'jansson' 'fuse2')
+makedepends=('git')
+conflicts=('tgfs')
+provides=('tgfs')
+
+source=("$pkgname"::'git+https://github.com/Firemoon777/tgfs')
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 bin/telegram-tgfs ${pkgdir}/usr/bin/telegram-tgfs
+ install -Dm755 bin/tgfs ${pkgdir}/usr/bin/tgfs
+}
+