summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Van de Velde2023-03-11 15:20:20 +0100
committerBruno Van de Velde2023-03-11 15:20:20 +0100
commitdc83adb762328717bc0213239065bb45514fe99e (patch)
treedbcbb3d9cf3394ef4af9f5664e1087ad83144564
parentd0a69f70413acb1172417bd7c2fe7c886adc801c (diff)
downloadaur-dc83adb762328717bc0213239065bb45514fe99e.tar.gz
Added .desktop file for Gui Builder
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--TexusGUI_48x48.pngbin0 -> 14283 bytes
-rw-r--r--tgui-gui-builder.desktop6
4 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10e580274587..179414e82481 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tgui-git
pkgdesc = Cross-platform modern c++ GUI library
- pkgver = nightly_build.r0.g6ef550515
+ pkgver = nightly_build.r0.g8719a201
pkgrel = 1
url = https://tgui.eu/
arch = i686
@@ -17,6 +17,10 @@ pkgbase = tgui-git
provides = tgui
conflicts = tgui
source = git+https://github.com/texus/TGUI.git#branch=0.10
+ source = tgui-gui-builder.desktop
+ source = TexusGUI_48x48.png
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = tgui-git
diff --git a/PKGBUILD b/PKGBUILD
index faf89886362e..165e2c86d4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bruno Van de Velde <bruno@texus.me>
pkgname=tgui-git
-pkgver=nightly_build.r0.g6ef550515
+pkgver=nightly_build.r0.g8719a201
pkgrel=1
pkgdesc="Cross-platform modern c++ GUI library"
arch=('i686' 'x86_64')
@@ -13,8 +13,12 @@ provides=('tgui')
conflicts=('tgui')
replaces=()
-source=("git+https://github.com/texus/TGUI.git#branch=0.10")
-sha256sums=('SKIP')
+source=("git+https://github.com/texus/TGUI.git#branch=0.10"
+ tgui-gui-builder.desktop
+ TexusGUI_48x48.png)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "${srcdir}/TGUI"
@@ -46,4 +50,6 @@ package() {
cd "$srcdir/TGUI"
make DESTDIR="$pkgdir/" install
install -Dm644 ./license.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ../TexusGUI_48x48.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/TexusGUI.png"
+ install -Dm644 ../tgui-gui-builder.desktop "${pkgdir}/usr/share/applications/tgui-gui-builder.desktop"
}
diff --git a/TexusGUI_48x48.png b/TexusGUI_48x48.png
new file mode 100644
index 000000000000..6568946501c7
--- /dev/null
+++ b/TexusGUI_48x48.png
Binary files differ
diff --git a/tgui-gui-builder.desktop b/tgui-gui-builder.desktop
new file mode 100644
index 000000000000..0277661ac1c7
--- /dev/null
+++ b/tgui-gui-builder.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=TGUI Gui Builder
+Icon=TexusGUI
+Exec=/usr/share/tgui-0.10/gui-builder/gui-builder