summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-06-09 00:23:40 +0100
committerEmmanuel Gil Peyrot2015-06-09 00:23:40 +0100
commitfb43759f641f596709c52aed8b403f34b6d4de03 (patch)
tree60a3d9e3c6a3f024387f6cc7e7e07b25168e52df
downloadaur-fb43759f641f596709c52aed8b403f34b6d4de03.tar.gz
Hello Gensokyo. _o/
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD68
-rw-r--r--th06-demo-pytouhou.desktop9
-rwxr-xr-xth06-demo-pytouhou.sh10
-rw-r--r--th06-demo-wine.desktop9
-rwxr-xr-xth06-demo-wine.sh40
6 files changed, 169 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4972d2d4d7ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = th06-demo
+ pkgver = 0.13
+ pkgrel = 3
+ url = http://www16.big.or.jp/~zun/html/th06.html
+ arch = any
+ license = custom
+ makedepends = convmv
+ makedepends = icoutils
+ source = http://www16.big.or.jp/~zun/data/soft/kouma_tr013.lzh
+ source = th06-demo-wine.desktop
+ source = th06-demo-wine.sh
+ source = th06-demo-pytouhou.desktop
+ source = th06-demo-pytouhou.sh
+ sha1sums = dfeb4dd358c6613ec4d8b701d41672ca75b6a0c9
+ sha1sums = 333378812ca70ba6c075abef71e6743e8cd331ca
+ sha1sums = 96bdc21f1e4f14bfeb19ff7025e83e658ec50f33
+ sha1sums = 93d2273e95886b29dfd94af22a485b0b50706ba8
+ sha1sums = 4591e137f7948508140c5014d11eacad41b63b0d
+
+pkgname = th06-demo-data
+ pkgdesc = Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; data files.
+
+pkgname = th06-demo-wine
+ pkgdesc = Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; Wine version.
+ depends = th06-demo-data
+ depends = wine
+ optdepends = timidity++: for MIDI musics
+
+pkgname = th06-demo-pytouhou
+ pkgdesc = Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; PyTouhou version.
+ depends = th06-demo-data
+ depends = pytouhou-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5d9e64f93d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgbase='th06-demo'
+pkgname=('th06-demo-data' 'th06-demo-wine' 'th06-demo-pytouhou')
+pkgver=0.13
+pkgrel=3
+url='http://www16.big.or.jp/~zun/html/th06.html'
+arch=('any')
+license=('custom')
+makedepends=('convmv' 'icoutils')
+source=('http://www16.big.or.jp/~zun/data/soft/kouma_tr013.lzh'
+ "$pkgbase-wine.desktop" "$pkgbase-wine.sh"
+ "$pkgbase-pytouhou.desktop" "$pkgbase-pytouhou.sh")
+sha1sums=('dfeb4dd358c6613ec4d8b701d41672ca75b6a0c9'
+ '333378812ca70ba6c075abef71e6743e8cd331ca'
+ '96bdc21f1e4f14bfeb19ff7025e83e658ec50f33'
+ '93d2273e95886b29dfd94af22a485b0b50706ba8'
+ '4591e137f7948508140c5014d11eacad41b63b0d')
+
+prepare() {
+ cd "$srcdir"
+ convmv -f CP932 -t UTF-8 -r --notest .
+}
+
+package_th06-demo-data() {
+ pkgdesc='Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; data files.'
+
+ cd "$srcdir/東方紅魔郷 体験版"
+
+ install -dm755 "$pkgdir/usr/share/$pkgbase"
+ install -m755 *.exe "$pkgdir/usr/share/$pkgbase"
+ install -m644 *.DAT "$pkgdir/usr/share/$pkgbase"
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgbase/html"
+ install -m644 *.txt 'マニュアル/index.html' "$pkgdir/usr/share/doc/$pkgbase"
+ install -m644 マニュアル/html/* "$pkgdir/usr/share/doc/$pkgbase/html"
+
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ wrestool -x -o th06-demo.ico 東方紅魔郷.exe
+ install -m644 th06-demo.ico "$pkgdir/usr/share/pixmaps"
+
+ # Here we convert the ico file to png, not sure if it’s worth it.
+ icotool -x th06-demo.ico
+ install -m644 th06-demo_1_32x32x8.png "$pkgdir/usr/share/pixmaps/th06-demo.png"
+}
+
+package_th06-demo-wine() {
+ pkgdesc='Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; Wine version.'
+ depends=("$pkgbase-data" 'wine')
+ optdepends=('timidity++: for MIDI musics')
+
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications"
+
+ install -dm755 "$pkgdir/usr/bin"
+ install -m755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}
+
+package_th06-demo-pytouhou() {
+ pkgdesc='Embodiment of Scarlet Devil trial version. Sixth game of the Touhou Project series; PyTouhou version.'
+ depends=("$pkgbase-data" 'pytouhou-hg')
+
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications"
+
+ install -dm755 "$pkgdir/usr/bin"
+ install -m755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/th06-demo-pytouhou.desktop b/th06-demo-pytouhou.desktop
new file mode 100644
index 000000000000..d9aaebec42a1
--- /dev/null
+++ b/th06-demo-pytouhou.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Touhou Koumakyou - Embodiment of Scarlet Devil; PyTouhou version
+Comment=Sixth game of the Touhou Project series
+Exec=/usr/bin/th06-demo-pytouhou
+Icon=th06-demo
+Categories=Game;
+Terminal=false
+StartupNotify=false
diff --git a/th06-demo-pytouhou.sh b/th06-demo-pytouhou.sh
new file mode 100755
index 000000000000..c6ad086d0371
--- /dev/null
+++ b/th06-demo-pytouhou.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+DEMO='/usr/share/th06-demo'
+
+if ! test -d "$DEMO"; then
+ echo 'You need to install the th06-demo-data from AUR to use this wrapper.'
+ exit 1
+fi
+
+exec pytouhou -p "$DEMO" "$@"
diff --git a/th06-demo-wine.desktop b/th06-demo-wine.desktop
new file mode 100644
index 000000000000..64706a56750e
--- /dev/null
+++ b/th06-demo-wine.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Touhou Koumakyou - Embodiment of Scarlet Devil; Wine version
+Comment=Sixth game of the Touhou Project series
+Exec=/usr/bin/th06-demo-wine
+Icon=th06-demo
+Categories=Game;
+Terminal=false
+StartupNotify=false
diff --git a/th06-demo-wine.sh b/th06-demo-wine.sh
new file mode 100755
index 000000000000..7e3f1682d36a
--- /dev/null
+++ b/th06-demo-wine.sh
@@ -0,0 +1,40 @@
+#!/bin/sh
+
+NAME='th06-demo'
+SRC="/usr/share/$NAME"
+DEST="$HOME/.local/share/$NAME"
+
+export WINEPREFIX="$DEST/wine"
+export WINEDLLOVERRIDES='mscoree,mshtml='
+export WINEARCH='win32'
+export LANG='ja_JP.UTF-8'
+
+# At the first launch, link the read-only data.
+if [ ! -d "$DEST" ] ; then
+ mkdir -p "$DEST"
+ mkdir -p "$WINEPREFIX"
+ ln -s "$SRC/東方紅魔郷.exe" "$DEST/"
+ ln -s "$SRC/custom.exe" "$DEST/"
+ for i in CM IN MD ST TL; do
+ ln -s "$SRC/紅魔郷$i.DAT" "$DEST/"
+ done
+fi
+
+# Launch the MIDI server if installed and not running.
+if [ '' != "`whereis timidity | grep '/usr/bin'`" ] ; then
+ if [ "`ps -A | grep timidity`" == '' ] ; then
+ timidity -iA &
+ myins='true'
+ fi
+fi
+
+cd "$DEST"
+
+# Launch the game
+wine 東方紅魔郷
+
+# End the MIDI server.
+if [ "$myins" == 'true' ] ; then
+ killall timidity
+fi
+