summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2018-01-06 01:57:09 -0600
committerChristopher Luna2018-01-06 01:57:09 -0600
commit4718155e4fbee71a77efe1506f40f705ea0dd82b (patch)
treeb0802d5959557aa4d2c497b5b5c5a2fd6aadd965
parent484ab2d3f84306f87296428788f02d6911cf1741 (diff)
downloadaur-4718155e4fbee71a77efe1506f40f705ea0dd82b.tar.gz
Removed lha dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--th07.sh10
3 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 978d13e5e160..762f5c61f6b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = th07
pkgdesc = Perfect cherry blossom trial version. Seventh game of the Touhou Project series. (via wine)
pkgver = 0.11
- pkgrel = 4
+ pkgrel = 5
url = http://www16.big.or.jp/~zun/html/th07.html
install = th07.install
arch = i686
arch = x86_64
license = custom
- makedepends = lha
depends = wine
optdepends = timidity++: to get MIDI background music
- noextract = youmu_tr011.lzh
options = !strip
source = th07.sh
source = th07.desktop
source = license
source = th07.xpm
source = http://www16.big.or.jp/~zun/data/soft/youmu_tr011.lzh
- md5sums = 68444481ddd6d84e18e801ef3b22db84
+ md5sums = 49ffef262520a2858e9c6cabc26e59a5
md5sums = 35d37eb00a1f7e6fc265f47e639ddfbc
md5sums = 5de1cb787942308b7620f93a176367d9
md5sums = ecdec576d60c662738e2495947543b95
diff --git a/PKGBUILD b/PKGBUILD
index d8b4c7dc6868..4d0c23a1f463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
pkgname=th07
pkgver=0.11
-pkgrel=4
+pkgrel=5
pkgdesc="Perfect cherry blossom trial version. Seventh game of the Touhou Project series. (via wine)"
arch=(i686 x86_64)
url="http://www16.big.or.jp/~zun/html/th07.html"
license=('custom')
depends=('wine')
-makedepends=(lha)
optdepends=('timidity++: to get MIDI background music')
source=(
th07.sh
@@ -17,25 +16,21 @@ source=(
th07.xpm
http://www16.big.or.jp/~zun/data/soft/youmu_tr011.lzh
)
-noextract=("youmu_tr011.lzh")
#http://homepage.ntlworld.com/steven.mitchell83/th07_english_patch_1%5b1%5d.0.exe)
install=${pkgname}.install
-md5sums=('68444481ddd6d84e18e801ef3b22db84'
+md5sums=('49ffef262520a2858e9c6cabc26e59a5'
'35d37eb00a1f7e6fc265f47e639ddfbc'
'5de1cb787942308b7620f93a176367d9'
'ecdec576d60c662738e2495947543b95'
'05360e859c1a3ca173b9d57d96a45b9b')
-
options=(!strip)
build() {
- cd $srcdir/
- lha e youmu_tr011.lzh
- cd youmu
- find -type d|grep -va '\(html\|^.$\)'|xargs -I dir mv "dir" th07man
+ cd $srcdir/youmu
+ mv $'\203'\}$'\203'j$'\203'$'\205'$'\203'A$'\203'$'\213' th07man
ls *.txt|grep -va '^[rc]'|xargs -I file mv file info.txt
}
package() {
diff --git a/th07.sh b/th07.sh
index 8021bbabd137..026bde26054e 100644
--- a/th07.sh
+++ b/th07.sh
@@ -13,10 +13,10 @@ if [ ! -f "$HOME"/.th07/th07.cfg ] ; then
echo "AAABAAIABAD//////////wMAAAACAAcAWAJYAgIDAAIBAQAAAgABAAAAAAAAAAAAAAAAAAEIAAA=" |base64 -d > "$HOME"/.th07/th07.cfg || exit 1
fi
-if [ "" != "`whereis timidity|grep '/usr/bin'`" ] ; then
- if [ "" == "`ps -A|grep timidity`" ] ; then
+if [ -n "`whereis timidity|grep '/usr/bin'`" ] ; then
+ if [ -z "`ps -A|grep timidity`" ] ; then
timidity -iA &
- myins="true"
+ timiditypid=$!
fi
fi
@@ -29,7 +29,7 @@ fi
if [ ! -e "$HOME"/.th07/th07e.exe ]; then
wine "$HOME"/.th07/th07.exe "$@"
fi
-if [ "true" == "$myins" ] ; then
- killall timidity
+if [ -n "$timiditypid" ]; then
+ kill $timiditypid
fi