summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2017-12-25 17:42:27 -0600
committerChristopher Luna2017-12-25 17:42:27 -0600
commit484ab2d3f84306f87296428788f02d6911cf1741 (patch)
tree5f41cc4f2d32e123494839bc28c13ef5026bb459
parentcfbff51fe004e37ed03203d714a1ba70eadc461c (diff)
downloadaur-484ab2d3f84306f87296428788f02d6911cf1741.tar.gz
Small update to depend on wine, not bin32-wine
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--th07.sh2
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781e006d650e..978d13e5e160 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = th07
pkgdesc = Perfect cherry blossom trial version. Seventh game of the Touhou Project series. (via wine)
pkgver = 0.11
- pkgrel = 3
+ pkgrel = 4
url = http://www16.big.or.jp/~zun/html/th07.html
install = th07.install
arch = i686
arch = x86_64
license = custom
makedepends = lha
+ depends = wine
optdepends = timidity++: to get MIDI background music
noextract = youmu_tr011.lzh
options = !strip
@@ -16,7 +17,7 @@ pkgbase = th07
source = license
source = th07.xpm
source = http://www16.big.or.jp/~zun/data/soft/youmu_tr011.lzh
- md5sums = b5fb7535a1ad78b53fd0bc6cdd5bd018
+ md5sums = 68444481ddd6d84e18e801ef3b22db84
md5sums = 35d37eb00a1f7e6fc265f47e639ddfbc
md5sums = 5de1cb787942308b7620f93a176367d9
md5sums = ecdec576d60c662738e2495947543b95
diff --git a/PKGBUILD b/PKGBUILD
index f94edad34f45..d8b4c7dc6868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,12 @@
pkgname=th07
pkgver=0.11
-pkgrel=3
+pkgrel=4
pkgdesc="Perfect cherry blossom trial version. Seventh game of the Touhou Project series. (via wine)"
arch=(i686 x86_64)
url="http://www16.big.or.jp/~zun/html/th07.html"
license=('custom')
-depends=()
-[ "$CARCH" = i686 ] && depends=(wine)
-[ "$CARCH" = x86_64 ] && depends=(bin32-wine)
+depends=('wine')
makedepends=(lha)
optdepends=('timidity++: to get MIDI background music')
source=(
@@ -23,11 +21,11 @@ noextract=("youmu_tr011.lzh")
#http://homepage.ntlworld.com/steven.mitchell83/th07_english_patch_1%5b1%5d.0.exe)
install=${pkgname}.install
-md5sums=('b5fb7535a1ad78b53fd0bc6cdd5bd018'
- '35d37eb00a1f7e6fc265f47e639ddfbc'
- '5de1cb787942308b7620f93a176367d9'
- 'ecdec576d60c662738e2495947543b95'
- '05360e859c1a3ca173b9d57d96a45b9b')
+md5sums=('68444481ddd6d84e18e801ef3b22db84'
+ '35d37eb00a1f7e6fc265f47e639ddfbc'
+ '5de1cb787942308b7620f93a176367d9'
+ 'ecdec576d60c662738e2495947543b95'
+ '05360e859c1a3ca173b9d57d96a45b9b')
diff --git a/th07.sh b/th07.sh
index 998d43fe29c9..8021bbabd137 100644
--- a/th07.sh
+++ b/th07.sh
@@ -1,6 +1,6 @@
#!/bin/bash
export WINEPREFIX="$HOME/.th07/wine"
-export WINEDLLOVERRIDES="mshtml="
+export WINEDLLOVERRIDES="mscoree=;mshtml="
if [ ! -d "$HOME"/.th07 ] ; then
mkdir -p "$HOME"/.th07/wine || exit 1