summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2015-06-08 16:21:33 -0500
committerChristopher Luna2015-06-08 16:21:33 -0500
commit3fd825af917485427e9f7cbf54ab8c109c6206ec (patch)
tree9a9296975477495ce85144f870b106831dfb2ea6
downloadaur-3fd825af917485427e9f7cbf54ab8c109c6206ec.tar.gz
First commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--license3
-rw-r--r--th08.desktop11
-rw-r--r--th08.install8
-rw-r--r--th08.sh37
6 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cee99677ea5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = th08
+ pkgdesc = The eighth game of the Touhou Project series, Imperishable Night trial version (via wine). Easy upgrade to full version.
+ pkgver = 0.03
+ pkgrel = 3
+ url = http://www16.big.or.jp/~zun/html/th08top.html
+ install = th08.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = timidity++: to get MIDI background music
+ options = !strip
+ source = th08.sh
+ source = th08.desktop
+ source = license
+ source = http://dl.dropbox.com/u/22186524/files/th08.png
+ source = http://mirror0.fuzzy2.com/zun/eiya_tr003.lzh
+ md5sums = 8eb909dd8b016ca81ac498c77876b693
+ md5sums = 8849405deb2bc3954c720468be36e8c4
+ md5sums = 5de1cb787942308b7620f93a176367d9
+ md5sums = c6cea48ee3d175b01d512f06481f8063
+ md5sums = c42647202a695bd1fdd2d88ce6615d53
+
+pkgname = th08
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90473feab119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: iruel <moot at 404chan dot tk>
+# Contributor (to th07 pkgbuild): chris_L <chrislcenter dash mamoru at yahoo.com dot mx>
+
+pkgname=th08
+pkgver=0.03
+pkgrel=3
+pkgdesc="The eighth game of the Touhou Project series, Imperishable Night trial version (via wine). Easy upgrade to full version."
+arch=(i686 x86_64)
+url="http://www16.big.or.jp/~zun/html/th08top.html"
+license=('custom')
+depends=()
+[ "$CARCH" = i686 ] && depends=(wine)
+[ "$CARCH" = x86_64 ] && depends=(bin32-wine)
+makedepends=()
+[ "$CARCH" = i686 ] && makedepends=(lha)
+[ "$CARCH" = x86_64 ] && makedepends=(bin32-lha)
+optdepends=('timidity++: to get MIDI background music')
+source=(th08.sh th08.desktop license http://dl.dropbox.com/u/22186524/files/th08.png http://mirror0.fuzzy2.com/zun/eiya_tr003.lzh)
+install=${pkgname}.install
+md5sums=('8eb909dd8b016ca81ac498c77876b693'
+'8849405deb2bc3954c720468be36e8c4'
+'5de1cb787942308b7620f93a176367d9'
+'c6cea48ee3d175b01d512f06481f8063'
+'c42647202a695bd1fdd2d88ce6615d53')
+
+noextract=()
+options=(!strip)
+
+build() {
+ cd $srcdir/
+ lha e eiya_tr003.lzh
+ cd eiya
+ find -type d|grep -v '\(html\|^.$\)'|xargs -I dir mv "dir" th08man
+ ls *.txt|grep -v '^[rc]'|xargs -I file mv file info.txt
+ cd ..
+ install -d -m755 $pkgdir/usr/share/
+ cp -R eiya $pkgdir/usr/share/$pkgname
+ mv $pkgdir/usr/share/$pkgname/th08tr.exe $pkgdir/usr/share/$pkgname/th08.exe
+ find $pkgdir/usr/share/th08 -type d -exec chmod 755 "{}" \;
+ find $pkgdir/usr/share/th08 -type f -exec chmod 644 "{}" \;
+ install -d -m755 $pkgdir/usr/bin
+ install -m755 th08.sh $pkgdir/usr/bin/$pkgname
+ install -d -m755 $pkgdir/usr/share/applications
+ install -d -m755 $pkgdir/usr/share/pixmaps
+ install -d -m755 $pkgdir/usr/share/licenses/$pkgname
+ install -m755 th08.desktop $pkgdir/usr/share/applications
+ install -m755 th08.png $pkgdir/usr/share/pixmaps/th08.png
+ install -m755 license $pkgdir/usr/share/licenses/$pkgname/license
+}
+
diff --git a/license b/license
new file mode 100644
index 000000000000..07f6d9696d9a
--- /dev/null
+++ b/license
@@ -0,0 +1,3 @@
+プログラム本体、イメージデータ、曲データ、及びマニュアル全ての著作権は製作者ZUNにあります。
+許可なしで複製、転載、配布を禁じます。
+2002,2003 (C)opyright ZUN. All rights reserved.
diff --git a/th08.desktop b/th08.desktop
new file mode 100644
index 000000000000..ac49ad391d31
--- /dev/null
+++ b/th08.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=0.11
+Type=Application
+Name=Touhou: Imperishable Night
+Comment=8th game of the Touhou Project
+Exec=/usr/bin/th08
+Encoding=UTF-8
+Icon=/usr/share/pixmaps/th08.png
+Categories=Game;
+Terminal=false
+StartupNotify=false
diff --git a/th08.install b/th08.install
new file mode 100644
index 000000000000..f4aa4bea0f6b
--- /dev/null
+++ b/th08.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Notice: If you have the full version of the game, you can copy the files into the ~/.th08 directory"
+ echo " "
+ echo "Also, if you are installing timidity++, remember to start the daemon before play as root with"
+ echo "# /etc/rc.d/timidity++ start"
+ echo "To make it permanent, add it to the DAEMONS section in your /etc/rc.conf."
+}
+
diff --git a/th08.sh b/th08.sh
new file mode 100644
index 000000000000..4fe6c5b4d30d
--- /dev/null
+++ b/th08.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+export WINEPREFIX="$HOME/.th08/wine"
+export WINEDLLOVERRIDES="mshtml="
+
+if [ ! -d "$HOME"/.th08 ] ; then
+ mkdir -p "$HOME"/.th08/wine || exit 1
+ ln -s /usr/share/th08/th08.exe "$HOME"/.th08/th08.exe || exit 1
+ ln -s /usr/share/th08/custom.exe "$HOME"/.th08/custom.exe || exit 1
+ ln -s /usr/share/th08/th08tr.dat "$HOME"/.th08/th08tr.dat || exit 1
+fi
+if [ ! -f "$HOME"/.th08/th08.cfg ] ; then
+ echo "AAABAAIABAD//////////wMAAAABAAgAWAJYAgIDAAIBAQAAAgAAZFAAAAAAAAAAAAAAAAAAAAABCAAA"|base64 -d >~/.th08/th08.cfg
+fi
+if [ "" != "`whereis timidity|grep '/usr/bin'`" ] ; then
+ if [ "" == "`ps -A|grep timidity`" ] ; then
+ timidity -iA &
+ myins="true"
+ fi
+fi
+# this sed is to make sure directinput is always activaded.
+# the controls can be a bit unresponsive without it
+mv ~/.th08/th08.cfg ~/.th08/th08.cfg.bak
+base64 th08.cfg.bak -w 0|sed 's/.\(...\)$/C\1/'|base64 -d>~/.th08/th08.cfg
+rm ~/.th08/th08.cfg.bak
+
+cd ~/.th08
+if [ -e "$HOME"/.th08/th08e.exe ]; then
+ wine "$HOME"/.th08/th08e.exe "$@"
+fi
+if [ ! -e "$HOME"/.th08/th08e.exe ]; then
+ wine "$HOME"/.th08/th08.exe "$@"
+fi
+if [ "true" == "$myins" ] ; then
+ killall timidity
+fi
+