summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-11-05 12:45:09 +0100
committeranthraxx2015-11-05 12:45:09 +0100
commit0e635fdd59652aaee54af112eca92711e5aabbd1 (patch)
tree29c7faab400a02de41a6d7a7eb6b62a9ec8a3ffe
downloadaur-0e635fdd59652aaee54af112eca92711e5aabbd1.tar.gz
addpkg: thc-ipv6-git 3.0.15.e5f1616-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f5c5809001f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thc-ipv6-git
+ pkgdesc = Complete tool set to attack the inherent protocol weaknesses of IPv6 and ICMP6
+ pkgver = 3.0.15.e5f1616
+ pkgrel = 1
+ url = https://thc.org/thc-ipv6/
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ depends = libpcap
+ depends = openssl
+ depends = libnetfilter_queue
+ provides = thc-ipv6
+ conflicts = thc-ipv6
+ source = thc-ipv6-git::git+https://github.com/vanhauser-thc/thc-ipv6
+ sha512sums = SKIP
+
+pkgname = thc-ipv6-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ffc49335352
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: henning mueller <mail@nning.io>
+# Contributor: Ariel Popper <a@arielp.com>
+# Contributor: mortzu <me@mortzu.de>
+
+pkgname=thc-ipv6-git
+_pkgname=${pkgname/-git}
+pkgver=3.0.15.e5f1616
+pkgrel=1
+pkgdesc='Complete tool set to attack the inherent protocol weaknesses of IPv6 and ICMP6'
+url='https://thc.org/thc-ipv6/'
+arch=('i686' 'x86_64')
+license=('AGPL3')
+depends=('libpcap' 'openssl' 'libnetfilter_queue')
+makedepends=('git')
+provides=('thc-ipv6')
+conflicts=('thc-ipv6')
+source=(${pkgname}::git+https://github.com/vanhauser-thc/${_pkgname})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(cat CHANGES|grep -E 'v[0-9\.]{3,}'| cut -d' ' -f1|cut -dv -f2|sort|tail -n1)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed 's|CFLAGS=|CFLAGS+=|g' -i Makefile
+}
+
+build() {
+ cd ${pkgname}
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm 644 README CHANGES HOWTO-INJECT -t "${pkgdir}/usr/share/doc/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: