summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxmani2023-09-03 18:01:04 +0300
committerMaxmani2023-09-03 18:01:04 +0300
commitbaf2c1ebdbc9d7fbfa85f04edf1262389561bac1 (patch)
treed3e97ecd9bc02aefedff6310d5bc4a732b47e320
downloadaur-baf2c1ebdbc9d7fbfa85f04edf1262389561bac1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dba3dcdd214
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = thcrap-steam-proton-wrapper-git
+ pkgdesc = A wrapper script for launching the official Touhou games on Steam with patches
+ pkgver = r24.519e82c
+ pkgrel = 1
+ url = https://github.com/tactikauan/thcrap-steam-proton-wrapper.git
+ arch = any
+ license = Unlicense
+ makedepends = git
+ depends = zenity
+ depends = procps-ng
+ depends = sed
+ depends = coreutils
+ source = thcrap-steam-proton-wrapper::git+https://github.com/tactikauan/thcrap-steam-proton-wrapper.git
+ sha256sums = SKIP
+
+pkgname = thcrap-steam-proton-wrapper-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07ae9de5e62d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mikael Hannukainen <mikael.hannukainen@gmail.com>
+pkgname=thcrap-steam-proton-wrapper-git
+_pkgname="${pkgname%-git}"
+pkgver=r24.519e82c
+pkgrel=1
+pkgdesc="A wrapper script for launching the official Touhou games on Steam with patches"
+arch=('any')
+url="https://github.com/tactikauan/thcrap-steam-proton-wrapper.git"
+license=('Unlicense')
+depends=('zenity' 'procps-ng' 'sed' 'coreutils')
+makedepends=('git')
+source=("$_pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "./thcrap_proton" "${pkgdir}/usr/bin/thcrap_proton"
+} \ No newline at end of file