summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerome Matilla2020-07-06 11:09:53 +0800
committerGerome Matilla2020-07-06 11:09:53 +0800
commitb37bf5d9f369e0167ced9e19a83c804a9ca9d7dd (patch)
treee883d1e28d30101ed9fc925853104d1fc1096308
downloadaur-b37bf5d9f369e0167ced9e19a83c804a9ca9d7dd.tar.gz
first commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD78
2 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e35c0edd921
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = the-glorious-dotfiles
+ pkgdesc = A glorified personal dot files
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/manilarome/the-glorious-dotfiles
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ depends = awesome-git
+ depends = rofi-git
+ depends = picom-tryone-git
+ optdepends = light-git: Brightness widget and OSD
+ optdepends = alsa-utils: Volume widget and OSD
+ optdepends = acpi: Power/Battery Widgets
+ optdepends = acpid: Power/Battery Widgets
+ optdepends = acpi_call: Power/Battery Widgets
+ optdepends = mpd: Music widget
+ optdepends = mpc: Music widget
+ optdepends = maim: Screenshot tool
+ optdepends = xclip: Will be used in saving the screenshots to clipboard
+ optdepends = imagemagick: Music widget/Extracts hardcoded album cover from songs
+ optdepends = blueman: Default launch application for bluetooth widget
+ optdepends = redshift: Blue light widget
+ optdepends = xfce4-power-manager: Default launch application for battery widget
+ optdepends = upower: Battery widget
+ optdepends = archlinux-xdg-menu: Menu Module/Useful for generating app list manually
+ optdepends = awesome-freedesktop-git: Menu Module/Useful for generating app list automatically
+ optdepends = jq: Read weather
+ optdepends = noto-fonts-emoji: Emoji support for notification center
+ optdepends = nerd-fonts-fantasque-sans-mono: Rofi unicode font
+ optdepends = xdg-user-dirs: xdg-folders widget
+ source = git+https://github.com/manilarome/the-glorious-dotfiles.git
+ sha256sums = SKIP
+
+pkgname = the-glorious-dotfiles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09c9bd72307f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: manilarome <gerome.matilla07@gmail.com>
+# Contributor: demostanis worlds <demostanis@protonmail.com>
+
+pkgname=the-glorious-dotfiles
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A glorified personal dot files"
+arch=("x86_64")
+url="https://github.com/manilarome/the-glorious-dotfiles"
+license=("AGPL3")
+depends=(
+ "awesome-git"
+ "rofi-git"
+ "picom-tryone-git"
+)
+optdepends=(
+ "light-git: Brightness widget and OSD"
+ "alsa-utils: Volume widget and OSD"
+ "acpi: Power/Battery Widgets"
+ "acpid: Power/Battery Widgets"
+ "acpi_call: Power/Battery Widgets"
+ "mpd: Music widget"
+ "mpc: Music widget"
+ "maim: Screenshot tool"
+ "xclip: Will be used in saving the screenshots to clipboard"
+ "imagemagick: Music widget/Extracts hardcoded album cover from songs"
+ "blueman: Default launch application for bluetooth widget"
+ "redshift: Blue light widget"
+ "xfce4-power-manager: Default launch application for battery widget"
+ "upower: Battery widget"
+ "archlinux-xdg-menu: Menu Module/Useful for generating app list manually"
+ "awesome-freedesktop-git: Menu Module/Useful for generating app list automatically"
+ "jq: Read weather"
+ "noto-fonts-emoji: Emoji support for notification center"
+ "nerd-fonts-fantasque-sans-mono: Rofi unicode font"
+ "xdg-user-dirs: xdg-folders widget"
+)
+makedepends=("git")
+source=("git+$url.git")
+sha256sums=("SKIP")
+
+package() {
+ DEST="${pkgdir}/usr/lib/$pkgname"
+
+ cd "${srcdir}/$pkgname"
+ mkdir -p $DEST
+ for file in $(find config/awesome -type f)
+ do
+ install -Dm755 ${file} $DEST/${file}
+ done
+
+ echo
+ echo "Here's a list of available themes:"
+ for t in $(ls config/awesome/)
+ do
+ echo -e " \033[1m$t\033[0m"
+ done
+ _ask
+}
+
+_ask() {
+ echo -n "Please choose one to install: "
+ read THEME
+
+ if [[ -d $DEST/config/awesome/$THEME ]]; then
+ [[ -d ~/.config/awesome ]] && \
+ cp -r ~/.config/awesome ~/.config/awesome.bak && \
+ rm -rf ~/.config/awesome && \
+ echo "Saved old awesome config to ~/.config/awesome.bak"
+ cp -r $DEST/config/awesome/$THEME ~/.config/awesome
+ echo "Successfully installed theme"
+ echo
+ elif [[ ! $THEME = "cancel" ]]; then
+ echo "Invalid theme"
+ _ask
+ fi
+}
+