summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-01-03 22:31:45 +1100
committerVictor Tran2017-01-03 22:31:45 +1100
commit7397d94c63bb0c7c31e1eac2073013dd5f4375a3 (patch)
tree724af2ac284f0ee4f511df8bbe660602585af3e6
downloadaur-7397d94c63bb0c7c31e1eac2073013dd5f4375a3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94d08fbf2c1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = the-libs
+ pkgdesc = Common libraries for the- applications by Victor Tran
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/the-libs
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ source = the-libs-1.0::git+https://github.com/vicr123/the-libs#branch=master
+ md5sums = SKIP
+
+pkgname = the-libs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e41ffe35cc94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=the-libs
+pkgver=1.0
+pkgrel=0
+pkgdesc="Common libraries for the- applications by Victor Tran"
+arch=("x86_64")
+url="https://github.com/vicr123/the-libs"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/the-libs#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/"
+ cp "$pkgname-$pkgver/"*.so* "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/lib/qt/mkspecs/modules/"
+ cp "$pkgname-$pkgver/qt_thelib.pri" "$pkgdir/usr/lib/qt/mkspecs/modules/"
+ mkdir -p "$pkgdir/usr/include/the-libs/"
+ cp "$pkgname-$pkgver/"*.h "$pkgdir/usr/include/the-libs/"
+}