summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah2021-03-15 09:37:41 -0700
committerNoah2021-03-15 09:37:41 -0700
commit58db8d2754797551e6e7c6cf5d59045080e1c3ea (patch)
tree51c34bc5c868040d562b50ac929fbd6217890e82
downloadaur-58db8d2754797551e6e7c6cf5d59045080e1c3ea.tar.gz
My first AUR package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83285944e839
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = the-rock
+ pkgdesc = A command line King James bible viewer
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/NoahJelen/the-rock
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ makedepends = git
+ depends = ncurses
+ conflicts = bible-kjv
+ source = git+https://gitlab.com/NoahJelen/the-rock
+ md5sums = SKIP
+
+pkgname = the-rock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..159aad63a9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Noah Jelen <noahtjelen@gmail.com>
+
+pkgname=the-rock
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A command line King James bible viewer"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/NoahJelen/the-rock"
+license=('GPL')
+depends=('ncurses')
+makedepends=('cargo')
+source=("https://gitlab.com/NoahJelen/the-rock/-/archive/0.1.0/the-rock-0.1.0.zip")
+conflicts=('the-rock-git')
+md5sums=('SKIP')
+
+build() {
+ ls
+ echo $PWD
+ cd "the-rock-0.1.0"
+ cargo build --release
+ cd target/release
+ ln -sf the_rock bible
+}
+
+package() {
+ #the package contents
+ cd "the-rock-0.1.0"
+ mkdir -p "$pkgdir/usr/lib/the_rock"
+ mkdir -p "$pkgdir/usr/share/man/man1/"
+ install -Dt "$pkgdir/usr/bin" -m755 target/release/the_rock
+ install -Dt "$pkgdir/usr/bin" -m755 target/release/bible
+ install -Dt "$pkgdir/usr/lib/the_rock/" bible.rawtext
+ install -Dt "$pkgdir/usr/share/applications/" the_rock.desktop
+ install -Dt "$pkgdir/usr/lib/the_rock/" icon.png
+
+ #the documentation
+ sudo install -Dt "$pkgdir/usr/share/man/man1" man/the_rock.1
+ sudo install -Dt "$pkgdir/usr/share/man/man1" man/bible.1
+ gzip "$pkgdir/usr/share/man/man1/bible.1"
+ gzip "$pkgdir/usr/share/man/man1/the_rock.1"
+}