summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYacob Zitouni2020-04-22 18:41:25 +0200
committerYacob Zitouni2020-04-22 18:41:25 +0200
commit2a37cf234ecf970cb3bc24fb2643f3127c9d9888 (patch)
tree511db779d254c1a574d645f2e7090a4a61a65224
downloadaur-2a37cf234ecf970cb3bc24fb2643f3127c9d9888.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..314d6e685f0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = the-sims-online-data
+ pkgdesc = The Sims Online game data. Patched with TSO-Version-Patcher to get the N&I version used by FreeSo
+ pkgver = 1.1097.1.0
+ pkgrel = 1
+ arch = x86_64
+ arch = i686
+ groups = games
+ license = custom:eula
+ makedepends = cabextract
+ makedepends = tso-version-patcher
+ source = http://archive.org/download/Fileplanet_dd_042006/Fileplanet_dd_042006.tar/042006/TSO_Installer_v1.1239.1.0.zip
+ sha256sums = 3b10be6fb736116ae32051e9ad7a506b224b5ef5d98139f0312eb2e6dcadcce4
+
+pkgname = the-sims-online-data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fad286ab37f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yacob Zitouni <yacobzitouni at gmail dot com>
+
+pkgname=the-sims-online-data
+pkgver=1.1097.1.0
+pkgrel=1
+pkgdesc="The Sims Online game data. Patched with TSO-Version-Patcher to get the N&I version used by FreeSo"
+license=('custom:eula')
+groups=('games')
+arch=('x86_64' 'i686')
+makedepends=('cabextract' 'tso-version-patcher')
+source=("http://archive.org/download/Fileplanet_dd_042006/Fileplanet_dd_042006.tar/042006/TSO_Installer_v1.1239.1.0.zip")
+sha256sums=('3b10be6fb736116ae32051e9ad7a506b224b5ef5d98139f0312eb2e6dcadcce4')
+
+prepare() {
+ cd "TSO_Installer_v1.1239.1.0"
+ # extract data file
+ cabextract -d ../tso-data Data1.cab
+ # patch to get right version
+ tso-version-patcher /usr/share/tso-version-patcher/1239toNI.tsop ../tso-data
+}
+
+package() {
+ cd "tso-data"
+
+ install -d "$pkgdir"/opt/the-sims-online-data
+ cp -r {TSOClient,TSOPatch,README.txt} "$pkgdir"/opt/the-sims-online-data/
+
+ cd "../TSO_Installer_v1.1239.1.0"
+
+ install -m 644 Setup/License.txt "$pkgdir"/opt/the-sims-online-data
+}