summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspikecodes2020-10-17 18:21:57 -0700
committerspikecodes2020-10-17 18:21:57 -0700
commitd942ffe5d38d0b03afcd02ca5a4a88ffb10f46be (patch)
treee19e261e6a7a560c7fbfefeb2d8fa2c86760fc0d
parenteb8dce0e333eba1a407ab09c2496dc598addfc3f (diff)
downloadaur-d942ffe5d38d0b03afcd02ca5a4a88ffb10f46be.tar.gz
Synced with Tagged Commits
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bae380198a95..741442a12b09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,13 @@ conflicts=(${pkgname})
source=("${pkgname}::git+${url}")
sha256sums=("SKIP")
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ printf "$(git describe --tags | awk -F- '{print $1}' | cut -c2-)"
+ )
+}
+
build() {
cd "${pkgname}"
cargo build --release