summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspikecodes2020-10-17 16:59:10 -0700
committerspikecodes2020-10-17 16:59:10 -0700
commiteb8dce0e333eba1a407ab09c2496dc598addfc3f (patch)
treec9243ec5d209b48ec6d9c52feffc177cd0e43dbd
downloadaur-eb8dce0e333eba1a407ab09c2496dc598addfc3f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7f7ab33e001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = the-way
+ pkgdesc = A command line code snippets manager
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/out-of-cheese-error/the-way
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ provides = the-way
+ conflicts = the-way
+ source = the-way::git+https://github.com/out-of-cheese-error/the-way
+ sha256sums = SKIP
+
+pkgname = the-way
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bae380198a95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: spikecodes <19519553+spikecodes@users.noreply.github.com>
+pkgname=the-way
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="A command line code snippets manager"
+arch=('any')
+url="https://github.com/out-of-cheese-error/the-way"
+license=("MIT")
+makedepends=("git" "cargo")
+provides=(${pkgname})
+conflicts=(${pkgname})
+source=("${pkgname}::git+${url}")
+sha256sums=("SKIP")
+
+build() {
+ cd "${pkgname}"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "${pkgname}/target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}