summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2020-07-30 23:30:59 +1000
committerVictor Tran2020-07-30 23:30:59 +1000
commit514f1937fef99f86143e01b49590ea74c35bc191 (patch)
treeb6c2c8486fe5f20ebaf52148d9a19692b0620993
downloadaur-514f1937fef99f86143e01b49590ea74c35bc191.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..682ae7d975a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = the24
+ pkgdesc = Clock app
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/the24
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ depends = libmusicbrainz5
+ depends = xdg-utils
+ depends = phonon-qt5
+ depends = qt5-base
+ depends = taglib
+ depends = the-libs
+ depends = qt5-svg
+ source = the24-1.0::https://github.com/vicr123/the24/archive/v1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = the24
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19e43525c8af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=the24
+pkgver=1.0
+pkgrel=0
+pkgdesc="Clock app"
+arch=("x86_64")
+url="https://github.com/vicr123/the24"
+license=('GPL3')
+depends=('libmusicbrainz5' 'xdg-utils' 'phonon-qt5' 'qt5-base' 'taglib' 'the-libs' 'qt5-svg')
+makedepends=('git' 'qt5-tools')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/the24/archive/v1.0.tar.gz")
+sha256sums=('12c9c76fbc9f32e3811faf4ee1ef26ac65c637152de63e594d70f55321d2f1c8')
+sha256sums=('SKIP')
+
+build() {
+ cd "the24-$pkgver"
+
+ mkdir build
+ cd build
+
+ qmake ../the24.pro
+ make
+}
+
+package() {
+ cd "the24-$pkgver/build"
+ make install INSTALL_ROOT=$pkgdir
+}