summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2018-10-11 21:43:30 +0200
committerpancho horrillo2018-10-11 21:43:30 +0200
commitfe7adc3baa83b20fa5894e7f418908faf43a1d9f (patch)
treee886b7481b729f9db1de4c1584521714622626da
parent3ae2143e01005e4197a4ba352c0b720bdd08fc72 (diff)
downloadaur-the_platinum_searcher.tar.gz
Bump to version 2.2.0
. Fix build by using godep properly. . Drop glibc from depends array, thanks to @GenkiSky for the heads up!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a5237b7b77..e68b8d125b33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Jul 7 18:26:21 UTC 2018
+# Thu Oct 11 19:41:52 UTC 2018
pkgbase = the_platinum_searcher
pkgdesc = A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).
- pkgver = 2.1.6
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/monochromegane/the_platinum_searcher
arch = x86_64
license = MIT
makedepends = git
makedepends = go
- depends = glibc
+ makedepends = godep
provides = the_platinum_searcher
conflicts = the_platinum_searcher-bin
source = git+https://github.com/monochromegane/the_platinum_searcher.git
diff --git a/PKGBUILD b/PKGBUILD
index aad2b2ce0bfc..f2efd34ce15a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,11 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=the_platinum_searcher
-pkgver=2.1.6
+pkgver=2.2.0
pkgrel=1
pkgdesc='A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).'
arch=('x86_64')
-makedepends=('git' 'go')
-depends=('glibc')
+makedepends=('git' 'go' 'godep')
url='https://github.com/monochromegane/the_platinum_searcher'
license=('MIT')
provides=('the_platinum_searcher')
@@ -23,20 +22,22 @@ build() {
cd "$_repodir/$pkgname"
git checkout -q v"$pkgver"
unset GOBIN # prevent bin to end up elsewhere
- GOPATH="$srcdir" go get -v ...
+ GOPATH="$srcdir" godep restore
+ GOPATH="$srcdir" godep go install -v ./...
}
check() {
- GOPATH="$srcdir" go test -v -x github.com/monochromegane/the_platinum_searcher/
+ cd "$_repodir/$pkgname"
+ GOPATH="$srcdir" godep go test -v -x .
}
package() {
msg 'Installing pt binary...'
- install -Dm 755 "$srcdir/bin/pt" "$pkgdir/usr/bin/pt"
+ install -Dm755 "$srcdir/bin/pt" "$pkgdir/usr/bin/pt"
msg 'Installing README...'
- install -Dm 644 "$_repodir/$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "$_repodir/$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
msg 'Installing LICENSE...'
- install -m 644 -D "$_repodir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$_repodir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}