summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2018-10-07 20:59:29 +0200
committerpancho horrillo2018-10-07 21:12:57 +0200
commit667f1b374530d40468e577998e41ed9820f103cb (patch)
tree54a7afa78b3738c0b08c7fc3c33ae89117d28bcb
parent1ee5648a8ee0b731a8ce3398755a90b8999f9725 (diff)
downloadaur-667f1b374530d40468e577998e41ed9820f103cb.tar.gz
Bump to version 2.2.0
Also drop spurious explicit dependency on glibc. Fixed minor style issues.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4bb2f165a2..a21b5aec5808 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Jul 8 05:06:51 UTC 2018
+# Sun Oct 7 19:12:40 UTC 2018
pkgbase = the_platinum_searcher-bin
pkgdesc = A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).
- pkgver = 2.1.6
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/monochromegane/the_platinum_searcher
arch = x86_64
license = MIT
- depends = glibc
provides = the_platinum_searcher
conflicts = the_platinum_searcher
- source_x86_64 = https://github.com/monochromegane/the_platinum_searcher/releases/download/v2.1.6/pt_linux_amd64.tar.gz
+ source_x86_64 = https://github.com/monochromegane/the_platinum_searcher/releases/download/v2.2.0/pt_linux_amd64.tar.gz
source_x86_64 = LICENSE
- sha512sums_x86_64 = 8bf310ca2508dafb761156e6b27dd7d71619df459012821bae42c4752dc58407809491e68db433ae48c252a81a00007f2634f2e752b993d8b86953ee45569bad
+ sha512sums_x86_64 = bb0da7b89b5c0c079588c1f3a0e755db0aeac189b676b8df1fa756bff13121e06e61f747c86cd22c92928db22db45b175155cd09b82ff87b289e83581a07c3e4
sha512sums_x86_64 = 58a1456e4267dc43f7e68071b6077c91516f576060d9a2fb645e47015adfc2dbffcae43e2ca81148bd1e0f0cae2cbe7ef2e147646579ed98bfaa44aa86c95680
pkgname = the_platinum_searcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index a8e8b98a6fac..4244fc7ef945 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,27 @@
pkgname=the_platinum_searcher-bin
pkgdesc='A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).'
-pkgver=2.1.6
+pkgver=2.2.0
pkgrel=1
arch=('x86_64')
url='https://github.com/monochromegane/the_platinum_searcher'
license=('MIT')
-depends=('glibc')
provides=('the_platinum_searcher')
conflicts=('the_platinum_searcher')
source_x86_64=(
- "https://github.com/monochromegane/the_platinum_searcher/releases/download/v$pkgver/pt_linux_amd64.tar.gz"
+ "$url/releases/download/v$pkgver/pt_linux_amd64.tar.gz"
LICENSE
)
-sha512sums_x86_64=(
- '8bf310ca2508dafb761156e6b27dd7d71619df459012821bae42c4752dc58407809491e68db433ae48c252a81a00007f2634f2e752b993d8b86953ee45569bad'
- '58a1456e4267dc43f7e68071b6077c91516f576060d9a2fb645e47015adfc2dbffcae43e2ca81148bd1e0f0cae2cbe7ef2e147646579ed98bfaa44aa86c95680'
-)
+sha512sums_x86_64=('bb0da7b89b5c0c079588c1f3a0e755db0aeac189b676b8df1fa756bff13121e06e61f747c86cd22c92928db22db45b175155cd09b82ff87b289e83581a07c3e4'
+ '58a1456e4267dc43f7e68071b6077c91516f576060d9a2fb645e47015adfc2dbffcae43e2ca81148bd1e0f0cae2cbe7ef2e147646579ed98bfaa44aa86c95680')
package() {
msg 'Installing pt binary...'
- install -Dm 755 "$srcdir/pt_linux_amd64/pt" "$pkgdir/usr/bin/pt"
+ install -Dm755 "$srcdir/pt_linux_amd64/pt" "$pkgdir/usr/bin/pt"
msg 'Installing README...'
- install -Dm 644 "$srcdir/pt_linux_amd64/README.md" "$pkgdir/usr/share/doc/${pkgname/-bin}/README.md"
+ install -Dm644 "$srcdir/pt_linux_amd64/README.md" "$pkgdir/usr/share/doc/${pkgname/-bin}/README.md"
msg 'Installing LICENSE...'
- install -m 644 -D LICENSE "$pkgdir/usr/share/licenses/${pkgname/-bin}/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname/-bin}/LICENSE"
}