summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2017-06-15 22:29:35 +0200
committerpancho horrillo2017-06-15 22:30:35 +0200
commit7c188175d252a109f2354236b1f9675c5bae060f (patch)
treef495b1964fd2b21d1b0cddf85a6e058538fa1366
parent5202ecb95f04d90fb724ba55b5a0f37c6dd3f129 (diff)
downloadaur-7c188175d252a109f2354236b1f9675c5bae060f.tar.gz
Install LICENSE, plus minor tweaks
-rw-r--r--.SRCINFO9
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a880a0d3333c..4e61770b83e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Jun 14 04:18:03 UTC 2017
+# Thu Jun 15 20:27:16 UTC 2017
pkgbase = the_platinum_searcher-bin
- pkgdesc = A code search tool similar to ack and the_silver_searcher(ag). Pre-compiled.
+ pkgdesc = A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).
pkgver = 2.1.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/monochromegane/the_platinum_searcher
arch = x86_64
license = MIT
+ depends = glibc
provides = the_platinum_searcher
conflicts = the_platinum_searcher
source_x86_64 = https://github.com/monochromegane/the_platinum_searcher/releases/download/v2.1.5/pt_linux_amd64.tar.gz
+ source_x86_64 = LICENSE
sha512sums_x86_64 = 1084d9b9054cfe66151d4751efb292e66d9369e330d67baa87b81aeb31e2eda29821b363933eaa10b2cd52c15fa2f5b8ed97c655db2c1f3ac76983e9d2844f2c
+ sha512sums_x86_64 = 58a1456e4267dc43f7e68071b6077c91516f576060d9a2fb645e47015adfc2dbffcae43e2ca81148bd1e0f0cae2cbe7ef2e147646579ed98bfaa44aa86c95680
pkgname = the_platinum_searcher-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ea4ad79cbcad
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) [2014] [the_platinum_searcher]
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 0eab7cfea693..b1dca0b0a060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
# Maintainer: pancho horrillo <pancho at pancho dot name>
pkgname=the_platinum_searcher-bin
-pkgdesc='A code search tool similar to ack and the_silver_searcher(ag). Pre-compiled.'
+pkgdesc='A code search tool similar to ack, the_silver_searcher (ag) and ripgrep (rg).'
pkgver=2.1.5
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://github.com/monochromegane/the_platinum_searcher'
license=('MIT')
-
+depends=('glibc')
provides=('the_platinum_searcher')
conflicts=('the_platinum_searcher')
+source_x86_64=(
+ "https://github.com/monochromegane/the_platinum_searcher/releases/download/v$pkgver/pt_linux_amd64.tar.gz"
+ LICENSE
+)
+sha512sums_x86_64=(
+ '1084d9b9054cfe66151d4751efb292e66d9369e330d67baa87b81aeb31e2eda29821b363933eaa10b2cd52c15fa2f5b8ed97c655db2c1f3ac76983e9d2844f2c'
+ '58a1456e4267dc43f7e68071b6077c91516f576060d9a2fb645e47015adfc2dbffcae43e2ca81148bd1e0f0cae2cbe7ef2e147646579ed98bfaa44aa86c95680'
+)
-source_x86_64=("https://github.com/monochromegane/the_platinum_searcher/releases/download/v$pkgver/pt_linux_amd64.tar.gz")
+package() {
+ msg 'Installing pt binary...'
+ install -Dm 755 "$srcdir/pt_linux_amd64/pt" "$pkgdir/usr/bin/pt"
-sha512sums_x86_64=('1084d9b9054cfe66151d4751efb292e66d9369e330d67baa87b81aeb31e2eda29821b363933eaa10b2cd52c15fa2f5b8ed97c655db2c1f3ac76983e9d2844f2c')
+ msg 'Installing README...'
+ install -Dm 644 "$srcdir/pt_linux_amd64/README.md" "$pkgdir/usr/share/doc/${pkgname/-bin}/README.md"
-package() {
- install -Dm 755 "$srcdir/pt_linux_amd64/pt" "$pkgdir/usr/bin/pt"
- install -Dm 644 "$srcdir/pt_linux_amd64/README.md" "$pkgdir/usr/share/doc/pt/README.md"
+ msg 'Installing LICENSE...'
+ install -m 644 -D LICENSE "$pkgdir/usr/share/licenses/${pkgname/-bin}/LICENSE"
}