summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPantelis Panayiotou2015-09-22 12:41:30 +0300
committerPantelis Panayiotou2015-09-22 12:41:30 +0300
commit4d0680c55980c2cbd630514bb0b3011759a83a14 (patch)
tree30fa9cfe2e454b1e9e0e3da26826d6fe3b50b6eb
downloadaur-4d0680c55980c2cbd630514bb0b3011759a83a14.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--config.install23
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c83bcf588fa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = thea-git
+ pkgdesc = A simple backup tool for desktop computers
+ pkgver = 20140105
+ pkgrel = 2
+ url = https://projects.kde.org/projects/playground/base/kio-mtp
+ install = config.install
+ arch = any
+ license = BSD
+ makedepends = make
+ depends = rsnapshot
+ depends = zsh
+ depends = yad
+ depends = sudo
+ depends = gksu
+ depends = colordiff
+ provides = thea
+ conflicts = thea
+
+pkgname = thea-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..025cf69bba7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+ pkgname=thea-git
+ _pkgname=thea
+ pkgver=20140105
+ pkgrel=2
+ pkgdesc="A simple backup tool for desktop computers"
+ arch=('any')
+ url="https://projects.kde.org/projects/playground/base/kio-mtp"
+ license=('BSD')
+ depends=('rsnapshot' 'zsh' 'yad' 'sudo' 'gksu' 'colordiff')
+ makedepends=('make')
+ conflicts=('thea')
+ provides=('thea')
+ install="config.install"
+ _gitroot="https://github.com/plp13/$_pkgname"
+ _gitname="$_pkgname"
+
+ build() {
+ cd $srcdir
+
+ if [ -d $_gitname ]
+ then
+ rm -fr $_gitname
+ fi
+ git clone $_gitroot $_gitname --depth=1
+
+ cd $srcdir/$_gitname
+ sed -e 's/\/usr\/local/\/usr/g' -i Makefile thea-*
+ }
+ package() {
+ cd $srcdir/$_gitname
+ make PREFIX=$pkgdir/usr install
+ mv $pkgdir/usr/share/thea/config $pkgdir/usr/share/thea/config.dist
+ }
diff --git a/config.install b/config.install
new file mode 100644
index 000000000000..80538431641c
--- /dev/null
+++ b/config.install
@@ -0,0 +1,23 @@
+post_install() {
+ if [ -f /usr/share/thea/config ]
+ then
+ echo "* A new Thea config file has been installed at /usr/share/thea/config.dist"
+ echo "* You should merge this file with your existing config file and run thea-config"
+ else
+ mv /usr/share/thea/config.dist /usr/share/thea/config
+ echo "* Thea's config file is located at /usr/share/thea/config"
+ echo "* You must now edit this file and run thea-config"
+ fi
+}
+
+post_upgrade() {
+ if [ -f /usr/share/thea/config ]
+ then
+ echo "* A new Thea config file has been installed at /usr/share/thea/config.dist"
+ echo "* You should merge this file with your existing config file and run thea-config"
+ else
+ mv /usr/share/thea/config.dist /usr/share/thea/config
+ echo "* Thea's config file is located at /usr/share/thea/config"
+ echo "* You must now edit this file and run thea-config"
+ fi
+}