summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-06-19 16:47:02 +1000
committerVictor Tran2017-06-19 16:47:02 +1000
commit47e7f0767f0e834d6b62132a85f43c6abfc0407d (patch)
tree244f5552876f2eecffbb83e2f072be6669a991df
downloadaur-47e7f0767f0e834d6b62132a85f43c6abfc0407d.tar.gz
Create version 0.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a05bc9d51497
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = thebeat
+ pkgdesc = Audio Player based on Phonon
+ pkgver = 0.1
+ pkgrel = 0
+ url = https://github.com/vicr123/thebeat
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = clang
+ depends = libmusicbrainz5
+ depends = xdg-utils
+ depends = phonon-qt5
+ depends = qt5-base
+ source = thebeat-0.1::git+https://github.com/vicr123/thebeat.git
+ md5sums = SKIP
+
+pkgname = thebeat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d50dadd8320e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=thebeat
+pkgver=0.1
+pkgrel=0
+pkgdesc="Audio Player based on Phonon"
+arch=("x86_64")
+url="https://github.com/vicr123/thebeat"
+license=('GPL3')
+depends=('libmusicbrainz5' 'xdg-utils' 'phonon-qt5' 'qt5-base')
+makedepends=('git' 'clang')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/thebeat.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/thebeat" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/thebeat.desktop" "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons"
+ cp "$srcdir/$pkgname-$pkgver/icon.svg" "$pkgdir/usr/share/icons/thebeat.svg"
+}