summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2022-02-10 14:30:49 +1100
committerVictor Tran2022-02-10 14:30:49 +1100
commit4638bde023617fa6da0498740f93d9420c84667f (patch)
tree5fa27081f66a23b9d157d5438b3ad1b3f5766933
parentb87594abb6f8a5739321a761f6e98d6b342b6a10 (diff)
downloadaur-4638bde023617fa6da0498740f93d9420c84667f.tar.gz
Update to rc1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a03e0a35463b..11a6d31a7664 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thedesk
pkgdesc = Desktop Environment built on Qt
- pkgver = beta4
- pkgrel = 3
+ pkgver = rc1
+ pkgrel = 1
url = https://github.com/vicr123/thedesk
arch = x86_64
license = GPL3
@@ -19,8 +19,9 @@ pkgbase = thedesk
makedepends = libtwebservices
makedepends = bluez-qt
makedepends = qrencode
- source = thedesk-beta4::https://github.com/vicr123/thedesk/archive/beta4.tar.gz
- sha256sums = fba59e6a6aa9940728f6e6e5db61445f44fbcc0adfa8b2f30f3e4c7649f4ac29
+ makedepends = thefile
+ source = thedesk-rc1::https://github.com/vicr123/thedesk/archive/rc1.tar.gz
+ sha256sums = e0a8320d4d6aacb5281698edb29f07563620773d371da565f30b7722f93d4681
pkgname = thedesk
depends = the-libs
@@ -41,12 +42,17 @@ pkgname = thedesk
depends = bluez-qt
depends = qrencode
depends = thedesk-xdg-utils
+ depends = xdg-desktop-portal-td
pkgname = td-polkitagent
depends = the-libs
depends = polkit-qt5
depends = libtdesktopenvironment
+pkgname = xdg-desktop-portal-td
+ depends = the-libs
+ depends = thefile
+
pkgname = thedesk-platform
depends = the-libs
depends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index 94cffae59fcb..23d063062e4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
-pkgname=('thedesk' 'td-polkitagent' 'thedesk-platform' 'libthedesk')
-pkgver=beta4
-pkgrel=3
+pkgname=('thedesk' 'td-polkitagent' 'xdg-desktop-portal-td' 'thedesk-platform' 'libthedesk')
+pkgver=rc1
+pkgrel=1
pkgdesc="Desktop Environment built on Qt"
arch=("x86_64")
url="https://github.com/vicr123/thedesk"
license=('GPL3')
-makedepends=('polkit-qt5' 'qt5-tools' 'the-libs' 'libtdesktopenvironment' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode')
-source=("thedesk-$pkgver"::'https://github.com/vicr123/thedesk/archive/beta4.tar.gz')
-sha256sums=('fba59e6a6aa9940728f6e6e5db61445f44fbcc0adfa8b2f30f3e4c7649f4ac29')
+makedepends=('polkit-qt5' 'qt5-tools' 'the-libs' 'libtdesktopenvironment' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode' 'thefile')
+source=("thedesk-$pkgver"::'https://github.com/vicr123/thedesk/archive/rc1.tar.gz')
+sha256sums=('e0a8320d4d6aacb5281698edb29f07563620773d371da565f30b7722f93d4681')
doInstallModule() {
pushd "$pkgbase-$pkgver/build/$1"
@@ -45,8 +45,14 @@ package_td-polkitagent() {
doInstallModule 'polkitagent';
}
+package_xdg-desktop-portal-td() {
+ depends=('the-libs' 'thefile')
+
+ doInstallModule 'desktop-portal'
+}
+
package_thedesk() {
- depends=('the-libs' 'kwin' 'libtdesktopenvironment' 'td-polkitagent' 'libthedesk' 'thedesk-platform' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'accountsservice' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode' 'thedesk-xdg-utils')
+ depends=('the-libs' 'kwin' 'libtdesktopenvironment' 'td-polkitagent' 'libthedesk' 'thedesk-platform' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'accountsservice' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode' 'thedesk-xdg-utils' 'xdg-desktop-portal-td')
doInstallModule 'desktop';
doInstallModule 'plugins';