summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2023-06-09 22:22:05 +1000
committerVictor Tran2023-06-09 22:22:05 +1000
commit969bdb1e6ac4766ed81f21f9f6af93938a4b6903 (patch)
tree61ab8fa37f36c6e6926915f84cd9ada5e85d01dc
parent4f6180b88d5a1b8c673b2e75d1ea35aadcbca5c0 (diff)
downloadaur-969bdb1e6ac4766ed81f21f9f6af93938a4b6903.tar.gz
Update to 1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96bbdd54d503..8991d82f04a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = thedesk-xdg-utils
- pkgver = beta1
+ pkgdesc = XDG Utilities for theDesk
+ pkgver = 1.0
pkgrel = 0
- url = https://github.com/vicr123/the24
+ url = https://github.com/theCheeseboard/thedesk-xdg-utils
arch = x86_64
+ arch = aarch64
license = GPL3
- makedepends = qt5-tools
- depends = qt5-base
- depends = qt5-svg
- depends = the-libs
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = cmake
+ makedepends = clang
depends = libtdesktopenvironment
- source = thedesk-xdg-utils-beta1::https://github.com/vicr123/thedesk-xdg-utils/archive/refs/tags/beta1.tar.gz
- sha256sums = 348f9378acc9035e1f04ea8962de482a092c7c578c7dd9fcf2f03e3581652a32
+ source = thedesk-xdg-utils-1.0::https://github.com/theCheeseboard/thedesk-xdg-utils/archive/refs/tags/v1.0.tar.gz
+ sha256sums = 550549f9bd82e01d18ad55b16c41496755f9955ea76f15fde6e7c96462c51f6d
pkgname = thedesk-xdg-utils
-
diff --git a/PKGBUILD b/PKGBUILD
index 71dfa4516151..647fede25a2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=thedesk-xdg-utils
-pkgver=beta1
+pkgver=1.0
pkgrel=0
-pkgdesc=""
-arch=("x86_64")
-url="https://github.com/vicr123/the24"
+pkgdesc="XDG Utilities for theDesk"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/thedesk-xdg-utils"
license=('GPL3')
-depends=('qt5-base' 'qt5-svg' 'the-libs' 'libtdesktopenvironment')
-makedepends=('qt5-tools')
-source=("$pkgname-$pkgver"::"https://github.com/vicr123/thedesk-xdg-utils/archive/refs/tags/beta1.tar.gz")
-sha256sums=('348f9378acc9035e1f04ea8962de482a092c7c578c7dd9fcf2f03e3581652a32')
+depends=('libtdesktopenvironment')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang')
+source=("$pkgname-$pkgver"::"https://github.com/theCheeseboard/thedesk-xdg-utils/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('550549f9bd82e01d18ad55b16c41496755f9955ea76f15fde6e7c96462c51f6d')
build() {
- cd "$pkgname-$pkgver"
-
- mkdir build
- cd build
-
- qmake ..
- make
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver/build"
- make install INSTALL_ROOT=$pkgdir
+ DESTDIR="$pkgdir" cmake --install "build"
}