summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2022-02-10 14:14:26 +1100
committerVictor Tran2022-02-10 14:15:25 +1100
commite4b6547049c25d56efd95ef4347a33b63babee21 (patch)
tree972d9eafbc07058d7c7122a65a2e490d00d45eac
parentb6c6c06238a0585015cc567d114a1d8618519c6e (diff)
downloadaur-e4b6547049c25d56efd95ef4347a33b63babee21.tar.gz
Update to 4.0.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcfd9a17df84..bf25c54fc535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = thefile
pkgdesc = File Manager
- pkgver = 4.0.1
+ pkgver = 4.0.2
pkgrel = 0
url = https://github.com/vicr123/thefile
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = qt5-tools
depends = xdg-utils
depends = qt5-base
@@ -12,7 +13,7 @@ pkgbase = thefile
depends = libtdesktopenvironment
depends = libthefrisbee
depends = qt5-svg
- source = thefile-4.0.1::https://github.com/vicr123/thefile/archive/refs/tags/v4.0.1.tar.gz
- sha256sums = f8184a2ce92d5be72af15b5a09e6c8f1e2f0bc240751afb6d267917374fc36f8
+ source = git+https://github.com/vicr123/thefile#tag=v4.0.2
+ sha256sums = SKIP
pkgname = thefile
diff --git a/PKGBUILD b/PKGBUILD
index 83c5d3b9986f..b226463c2012 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=thefile
-pkgver=4.0.1
+pkgver=4.0.2
pkgrel=0
pkgdesc="File Manager"
arch=("x86_64")
url="https://github.com/vicr123/thefile"
license=('GPL3')
depends=('xdg-utils' 'qt5-base' 'the-libs' 'libtdesktopenvironment' 'libthefrisbee' 'qt5-svg')
-makedepends=('qt5-tools')
-source=("$pkgname-$pkgver"::"https://github.com/vicr123/thefile/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('f8184a2ce92d5be72af15b5a09e6c8f1e2f0bc240751afb6d267917374fc36f8')
+makedepends=('git' 'qt5-tools')
+source=("git+https://github.com/vicr123/thefile#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "thefile-$pkgver"
+ cd thefile
mkdir -p build
cd build
qmake ../theFile.pro
@@ -20,7 +20,6 @@ build() {
}
package() {
- cd "thefile-$pkgver"
- cd build
+ cd thefile/build
make install INSTALL_ROOT=$pkgdir
}