summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-08-22 00:24:04 +1000
committerVictor Tran2017-08-22 00:24:04 +1000
commit96d8ff3e257074b7cf09aa530c06f81ab849ff3e (patch)
tree6e1e4420ffd6f7c198007ceac6f0b14766418567
downloadaur-96d8ff3e257074b7cf09aa530c06f81ab849ff3e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--thefile-b.desktop9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66f01fe46f07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = thefile-blueprint
+ pkgdesc = Simple File Manager
+ pkgver = 4.0
+ pkgrel = 0
+ url = https://github.com/vicr123/thefile
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = xdg-utils
+ depends = qt5-base
+ source = thefile-blueprint-4.0::git+https://github.com/vicr123/thefile#branch=rewrite
+ source = thefile-b.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = thefile-blueprint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8808d1855137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=thefile-blueprint
+pkgver=4.0
+pkgrel=0
+pkgdesc="Simple File Manager"
+arch=("x86_64")
+url="https://github.com/vicr123/thefile"
+license=('GPL2')
+depends=('xdg-utils' 'qt5-base')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/thefile#branch=rewrite'
+ "thefile-b.desktop")
+md5sums=('SKIP'
+ 'SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
+ cd $srcdir
+ rm $pkgdir/usr/share/applications/thefile.desktop
+ cp "thefile-b.desktop" "$pkgdir/usr/share/applications"
+ mv $pkgdir/usr/bin/thefile $pkgdir/usr/bin/thefile-b
+}
diff --git a/thefile-b.desktop b/thefile-b.desktop
new file mode 100644
index 000000000000..eef65a608538
--- /dev/null
+++ b/thefile-b.desktop
@@ -0,0 +1,9 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=theFile
+GenericName=File Manager
+Exec=thefile-b
+Icon=system-file-manager
+MimeType=inode/directory