summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaal2023-02-20 09:17:19 +0100
committerBaal2023-02-20 09:17:19 +0100
commit581bc70f24bd08368277d9bcedc36fbb1b3cdc4d (patch)
tree71ee8ecea06e8844d046cf30399f224df782805f
parent01d3eccef88d4ea77a31493ac32373e1a59f0e42 (diff)
downloadaur-581bc70f24bd08368277d9bcedc36fbb1b3cdc4d.tar.gz
update to hotfix 1.09.100. there is a dependency on either kdialog or zenity. this is not expressed in the PKGBUILD so I added a message
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
-rw-r--r--theforceengine.install11
4 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9ee1076cdf2..c1300fcdbd63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theforceengine
pkgdesc = Modern "Jedi Engine" replacement supporting Dark Forces, Outlaws and the mods
- pkgver = 1.09.000
+ pkgver = 1.09.100
pkgrel = 1
url = https://theforceengine.github.io/
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = theforceengine
depends = rtaudio
depends = rtmidi
depends = hicolor-icon-theme
- source = TheForceEngine::git+https://github.com/luciusDXL/TheForceEngine.git#tag=3b216b52286bff7176b131cfa692475f2aae09eb
+ source = TheForceEngine::git+https://github.com/luciusDXL/TheForceEngine.git#tag=00c87198486cb9ccf10fa4f4ac1980435f0837a6
+ source = theforceengine.install
sha256sums = SKIP
+ sha256sums = 3970ca1539bfdfd0f87c5bdcca7ba6847037f1d72614b2a8067d35dd1ad0b5bb
pkgname = theforceengine
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..3f0758463e59 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
*
+!theforceengine.install
!.gitignore
!.SRCINFO
!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index b497c0564023..23e924ff9b84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Baal <weiss.sebastian@gmx.net
pkgname=theforceengine
-pkgver=1.09.000
+pkgver=1.09.100
pkgrel=1
pkgdesc="Modern \"Jedi Engine\" replacement supporting Dark Forces, Outlaws and the mods"
arch=('x86_64')
@@ -10,9 +10,11 @@ license=('GPL2')
depends=("libgl" "sdl2" "devil" "glew" "rtaudio" "rtmidi" "hicolor-icon-theme")
makedepends=("cmake" "ninja" "git")
optdepends=()
-_tag=3b216b52286bff7176b131cfa692475f2aae09eb
-source=("TheForceEngine::git+https://github.com/luciusDXL/TheForceEngine.git#tag=$_tag")
-sha256sums=(SKIP)
+_tag=00c87198486cb9ccf10fa4f4ac1980435f0837a6
+source=("TheForceEngine::git+https://github.com/luciusDXL/TheForceEngine.git#tag=$_tag"
+ "theforceengine.install")
+sha256sums=('SKIP'
+ '3970ca1539bfdfd0f87c5bdcca7ba6847037f1d72614b2a8067d35dd1ad0b5bb')
pkgver() {
cd TheForceEngine
diff --git a/theforceengine.install b/theforceengine.install
new file mode 100644
index 000000000000..129e002cad79
--- /dev/null
+++ b/theforceengine.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<- EOF
+ :: KDialog or Zenity are used to display file dialogs.
+ :: This is not (yet) expressed in the PKGBUILD, so make sure
+ :: at least one of them is installed on your system.
+ EOF
+}
+
+post_upgrade() {
+ post_install $1
+}