summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorocelot2019-03-10 15:24:40 +1100
committerocelot2019-03-10 15:24:40 +1100
commit2b1ac62838f129db5f91a426a3af687b368c2acb (patch)
tree82383b395fc8e0e2837eb175786bcc2f5d0d6c31
parent045526189208553776b560ea0a4c2019c5792b1f (diff)
parent8db8997feb4419b3e0ee21a79cfa864be08f006e (diff)
downloadaur-2b1ac62838f129db5f91a426a3af687b368c2acb.tar.gz
conflict resolution
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
-rw-r--r--theHarvester.install9
4 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b054376e4a5..d43f8a8944d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theharvester-git
pkgdesc = A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers).
- pkgver = 3.0.6.r220.gefe73e2
+ pkgver = 3.0.6.r264.g21939b0
pkgrel = 1
url = https://github.com/laramies/theHarvester
install = theHarvester.install
@@ -10,6 +10,7 @@ pkgbase = theharvester-git
makedepends = bash
depends = bash
depends = python
+ depends = python-yaml
depends = python-requests
depends = python-plotly
depends = python-pytest
@@ -17,6 +18,7 @@ pkgbase = theharvester-git
depends = python-shodan
depends = python-beautifulsoup4
depends = python-yaml
+ depends = python-decorator
provides = theharvester-git
conflicts = theharvester-git
source = theharvester-git::git+https://github.com/laramies/theHarvester.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d92d0dd6a191
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+stash.sqlite
diff --git a/PKGBUILD b/PKGBUILD
index e20626466306..05497e09170e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# Maintainer: Sebastian Neef <aur AT gehaxelt DOT IN>
pkgbase=theharvester-git
pkgname=theharvester-git
-pkgver=3.0.6.r220.gefe73e2
+pkgver=3.0.6.r264.g21939b0
pkgrel=1
pkgdesc="A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers)."
arch=('any')
url="https://github.com/laramies/theHarvester"
license=('GPL2')
depends=(
- 'bash'
- 'python'
- 'python-requests'
- 'python-plotly'
- 'python-pytest'
- 'python-texttable'
- 'python-shodan'
- 'python-beautifulsoup4'
- 'python-yaml')
+ 'bash'
+ 'python'
+ 'python-yaml'
+ 'python-requests'
+ 'python-plotly'
+ 'python-pytest'
+ 'python-texttable'
+ 'python-shodan'
+ 'python-beautifulsoup4'
+ 'python-yaml'
+ 'python-decorator'
+)
makedepends=('git' 'bash')
provides=("${pkgname}")
conflicts=("${pkgname}")
diff --git a/theHarvester.install b/theHarvester.install
index 7f592fc37d9b..5baa2eeab336 100644
--- a/theHarvester.install
+++ b/theHarvester.install
@@ -2,8 +2,9 @@ post_install() {
echo "NOTE: the Censys python module has been added upstream as a dependency, but is not available as an Archlinux package. For now, please use "easy_install censys" if you wish to use the censys functionalities."
echo "IMPORTANT: The location of API keys has changed!"
echo "Add your keys to /opt/theharvester-git/api-keys.yaml"
- echo " googleCSE: API key and CSE ID"
- echo " hunter: API key"
- echo " securitytrails: API key"
- echo " shodan: API key"
+ echo " bingapi"
+ echo " hunter"
+ echo " intelx"
+ echo " securitytrails"
+ echo " shodan"
}