summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorocelot2019-01-25 00:42:23 +1100
committerocelot2019-01-25 00:42:23 +1100
commit4080ca588159de755e306fa934039c31afb0681a (patch)
tree2cb19fcb663aca5431046e25c27012253c30f9dd
parent4d55db691c268880f30cf254a2a0d6c89a8aaddd (diff)
downloadaur-4080ca588159de755e306fa934039c31afb0681a.tar.gz
remove stash.py, add bs4, fix version
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e82534a6f2a..f3f21a13a622 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theharvester-git
pkgdesc = A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers).
- pkgver = r470.759992d
+ pkgver = 3.0.6.r220.gefe73e2
pkgrel = 1
url = https://github.com/laramies/theHarvester
install = theHarvester.install
@@ -15,6 +15,7 @@ pkgbase = theharvester-git
depends = python-pytest
depends = python-texttable
depends = python-shodan
+ depends = python-beautifulsoup4
provides = theharvester-git
conflicts = theharvester-git
source = theharvester-git::git+https://github.com/laramies/theHarvester.git
diff --git a/PKGBUILD b/PKGBUILD
index 6915e731f460..7c35c990573d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Neef <aur AT gehaxelt DOT IN>
pkgbase=theharvester-git
pkgname=theharvester-git
-pkgver=r470.759992d
+pkgver=3.0.6.r220.gefe73e2
pkgrel=1
pkgdesc="A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers)."
arch=('any')
@@ -14,7 +14,8 @@ depends=(
'python-plotly'
'python-pytest'
'python-texttable'
- 'python-shodan')
+ 'python-shodan'
+ 'python-beautifulsoup4')
makedepends=('git' 'bash')
provides=("${pkgname}")
conflicts=("${pkgname}")
@@ -23,10 +24,8 @@ source=("$pkgname::git+https://github.com/laramies/theHarvester.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- ( set -o pipefail
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -46,10 +45,9 @@ package() {
cp -r "$srcdir/$pkgname/parsers" "$pkgdir/opt/$pkgname/"
cp -r "$srcdir/$pkgname/tests" "$pkgdir/opt/$pkgname/"
cp -r "$srcdir/$pkgname/wordlists" "$pkgdir/opt/$pkgname/"
- install "$srcdir/$pkgname/stash.py" "$pkgdir/opt/$pkgname/"
+ install "$srcdir/$pkgname/api-keys.yaml" "$pkgdir/opt/$pkgname/"
install "$srcdir/$pkgname/theHarvester.py" "$pkgdir/opt/$pkgname/"
install "$srcdir/$pkgname/run.sh" "$pkgdir/opt/$pkgname/"
-
- ln -s "/opt/$pkgname/run.sh" "$pkgdir/usr/bin/theharvester"
-
+
+ ln -s "/opt/$pkgname/run.sh" "$pkgdir/usr/bin/theharvester"
}