summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTK2019-04-09 10:00:07 +1000
committerTK2019-04-09 10:00:07 +1000
commit65ef3e3b9ebfae3f0ff328fcf4fd7cb75fea4730 (patch)
tree3acab7de66520e42602f386c8df326a13de82d23
parentd9fdb1ecb98260698f024a8b08951b40ba64ff04 (diff)
parent553f1d2cda10d6e3bdd5f8fdeb502a393f912c8c (diff)
downloadaur-65ef3e3b9ebfae3f0ff328fcf4fd7cb75fea4730.tar.gz
merge
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d2e8119de1e..d2924e405426 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theharvester-git
pkgdesc = A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers).
- pkgver = 3.0.6.r264.g21939b0
+ pkgver = 3.0.6.r349.g35b322e
pkgrel = 1
url = https://github.com/laramies/theHarvester
install = theHarvester.install
@@ -17,7 +17,9 @@ pkgbase = theharvester-git
depends = python-texttable
depends = python-shodan
depends = python-beautifulsoup4
+ depends = python-yaml
depends = python-decorator
+ depends = python-censys
provides = theharvester-git
conflicts = theharvester-git
source = theharvester-git::git+https://github.com/laramies/theHarvester.git
diff --git a/PKGBUILD b/PKGBUILD
index 37774c18f97b..4820c5223d07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,19 @@ arch=('any')
url="https://github.com/laramies/theHarvester"
license=('GPL2')
depends=(
- 'bash'
- 'python'
- 'python-yaml'
- 'python-requests'
- 'python-plotly'
- 'python-pytest'
- 'python-texttable'
- 'python-shodan'
- 'python-beautifulsoup4'
- 'python-decorator')
+ 'bash'
+ 'python'
+ 'python-yaml'
+ 'python-requests'
+ 'python-plotly'
+ 'python-pytest'
+ 'python-texttable'
+ 'python-shodan'
+ 'python-beautifulsoup4'
+ 'python-yaml'
+ 'python-decorator'
+ 'python-censys'
+)
makedepends=('git' 'bash')
provides=("${pkgname}")
conflicts=("${pkgname}")
@@ -52,3 +55,8 @@ package() {
ln -s "/opt/$pkgname/run.sh" "$pkgdir/usr/bin/theharvester"
}
+
+check(){
+ cd "${srcdir}"
+ pytest
+}