summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-02-27 22:25:21 -0500
committeréclairevoyant2023-02-27 22:25:21 -0500
commit7bcdd4149ce7a44c7fc2fa91550bda685bfbf9ec (patch)
tree063d99934603ca55f5b40d9be0f3f0cec9a51d36
parent213eba0ff609e550f931db505c45677907e892e8 (diff)
downloadaur-7bcdd4149ce7a44c7fc2fa91550bda685bfbf9ec.tar.gz
theharvester-git: update deps
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD74
3 files changed, 50 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fc0ac34e39a..7c6fce1adbd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theharvester-git
- pkgdesc = An OSINT tool for gathering emails, names, subdomains, IPs and URLs related to a target using public sources.
- pkgver = 3.2.3.r18.ga6959ad
+ pkgdesc = Gather emails, names, subdomains, IPs and URLs related to targets using public sources
+ pkgver = 4.2.0.r254.g5065d6c
pkgrel = 1
url = https://github.com/laramies/theHarvester
install = theHarvester.install
@@ -9,28 +9,28 @@ pkgbase = theharvester-git
makedepends = git
makedepends = python-setuptools
makedepends = python-pytest
- depends = python
depends = python-aiodns
+ depends = python-aiofiles
depends = python-aiohttp
depends = python-aiomultiprocess
depends = python-aiosqlite
+ depends = python-argparse
depends = python-beautifulsoup4
+ depends = python-censys
depends = python-certifi
depends = python-dnspython
+ depends = python-fastapi
+ depends = python-lxml
depends = python-netaddr
- depends = python-plotly
+ depends = python-ujson
depends = python-pyppeteer
depends = python-yaml
depends = python-requests
depends = python-retrying
depends = python-shodan
- depends = python-texttable
- depends = python-lxml
+ depends = uvicorn
depends = python-uvloop
- provides = theharvester-git
- conflicts = theharvester-git
source = theharvester-git::git+https://github.com/laramies/theHarvester.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = theharvester-git
-
diff --git a/.gitignore b/.gitignore
index 4d816fcbbb93..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-stash.sqlite
-pkg/
-src/
-theharvester-git*
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index c7e2a591f045..45589318ca48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,56 @@
-# Maintainer: dkasak <dkasak AT termina DOT org DOT uk>
-# Contributor: Sebastian Neef <aur AT gehaxelt DOT IN>
-# Contributor: ocelot <amitchell AT airmail DOT cc>
+# Maintainer: éclairevoyant
-pkgbase=theharvester-git
pkgname=theharvester-git
-pkgver=3.2.3.r18.ga6959ad
+pkgver=4.2.0.r254.g5065d6c
pkgrel=1
-pkgdesc="An OSINT tool for gathering emails, names, subdomains, IPs and URLs related to a target using public sources."
+pkgdesc="Gather emails, names, subdomains, IPs and URLs related to targets using public sources"
arch=('any')
url="https://github.com/laramies/theHarvester"
license=('GPL2')
depends=(
- 'python'
- 'python-aiodns'
- 'python-aiohttp'
- 'python-aiomultiprocess'
- 'python-aiosqlite'
- 'python-beautifulsoup4'
- 'python-certifi'
- 'python-dnspython'
- 'python-netaddr'
- 'python-plotly'
- 'python-pyppeteer'
- 'python-yaml'
- 'python-requests'
- 'python-retrying'
- 'python-shodan'
- 'python-texttable'
- 'python-lxml'
- 'python-uvloop'
+ 'python-aiodns'
+ 'python-aiofiles'
+ 'python-aiohttp'
+ 'python-aiomultiprocess'
+ 'python-aiosqlite'
+ 'python-argparse'
+ 'python-beautifulsoup4'
+ 'python-censys'
+ 'python-certifi'
+ 'python-dnspython'
+ 'python-fastapi'
+ 'python-lxml'
+ 'python-netaddr'
+ 'python-ujson'
+ 'python-pyppeteer'
+ 'python-yaml'
+ 'python-requests'
+ 'python-retrying'
+ 'python-shodan'
+ 'uvicorn'
+ 'python-uvloop'
)
makedepends=('git' 'python-setuptools' 'python-pytest')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
install="theHarvester.install"
-source=("$pkgname::git+https://github.com/laramies/theHarvester.git")
-sha256sums=('SKIP')
+source=("$pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
- python setup.py build
+ cd $pkgname
+ python setup.py build
}
-package() {
- cd "${srcdir}/${pkgname}"
- python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+check() {
+ cd $pkgname
+ pytest
}
-check() {
- cd "${srcdir}/${pkgname}"
- pytest
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}