summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorocelot2019-03-11 01:56:49 +1100
committerocelot2019-03-11 01:56:49 +1100
commitca3835729b20eec4b6f91dae227e84fa93aa6a7f (patch)
tree1a76f0861767317357e7c8f1dea0b02c6389427d
parent2b1ac62838f129db5f91a426a3af687b368c2acb (diff)
downloadaur-ca3835729b20eec4b6f91dae227e84fa93aa6a7f.tar.gz
add python-censys
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD1
-rw-r--r--theHarvester.install1
3 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d43f8a8944d..a4efaa5ea37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,6 +19,7 @@ pkgbase = theharvester-git
depends = python-beautifulsoup4
depends = python-yaml
depends = python-decorator
+ depends = python-censys
provides = theharvester-git
conflicts = theharvester-git
source = theharvester-git::git+https://github.com/laramies/theHarvester.git
diff --git a/PKGBUILD b/PKGBUILD
index 05497e09170..fa505cd455e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,7 @@ depends=(
'python-beautifulsoup4'
'python-yaml'
'python-decorator'
+ 'python-censys'
)
makedepends=('git' 'bash')
provides=("${pkgname}")
diff --git a/theHarvester.install b/theHarvester.install
index 5baa2eeab33..7a417b072ae 100644
--- a/theHarvester.install
+++ b/theHarvester.install
@@ -1,5 +1,4 @@
post_install() {
- echo "NOTE: the Censys python module has been added upstream as a dependency, but is not available as an Archlinux package. For now, please use "easy_install censys" if you wish to use the censys functionalities."
echo "IMPORTANT: The location of API keys has changed!"
echo "Add your keys to /opt/theharvester-git/api-keys.yaml"
echo " bingapi"