summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2021-09-04 12:04:33 +0200
committerBence Hornák2021-09-04 12:04:33 +0200
commit1e2de3472ba66ff0cc141d984844610e38a1b0aa (patch)
treee7d144d8a07c7afc10e9caf84e82b749c7eb1c85
parent830137bf389abc23e6adb5670469e61068947020 (diff)
downloadaur-1e2de3472ba66ff0cc141d984844610e38a1b0aa.tar.gz
Upgrade to v1.17.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--package.json96
3 files changed, 54 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d39b3db0fc8..6399a4d59123 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.16.0
+ pkgver = 1.17.2
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -23,10 +23,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.16.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.16.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.17.2/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.17.2/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = 644ba3afe6ad93ad91afd9eabb461f04
+ md5sums = 062238557d2445880d5dbbad585169ce
md5sums = 8a3461a9d1c50f6bfe60902d020bb797
md5sums = d387a0df41b11ba3d33360812bfbbe2c
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index f9565be306fc..f4c1268f6e61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leon De Andrade <leondeandrade@hotmail.com>
pkgname=theia-electron
-pkgver=1.16.0
+pkgver=1.17.2
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -22,7 +22,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- '644ba3afe6ad93ad91afd9eabb461f04'
+ '062238557d2445880d5dbbad585169ce'
'8a3461a9d1c50f6bfe60902d020bb797'
'd387a0df41b11ba3d33360812bfbbe2c'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 7df8f88fc854..e4f8c07da842 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.16.0",
+ "version": "1.17.2",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -33,6 +33,7 @@
"vscode-builtin-hlsl": "https://open-vsx.org/api/vscode/hlsl/1.50.0/file/vscode.hlsl-1.50.0.vsix",
"vscode-builtin-html": "https://open-vsx.org/api/vscode/html/1.50.0/file/vscode.html-1.50.0.vsix",
"vscode-builtin-html-language-features": "https://open-vsx.org/api/vscode/html-language-features/1.50.0/file/vscode.html-language-features-1.50.0.vsix",
+ "vscode-builtin-icon-theme-seti": "https://open-vsx.org/api/vscode/vscode-theme-seti/1.50.0/file/vscode.vscode-theme-seti-1.50.0.vsix",
"vscode-builtin-ini": "https://open-vsx.org/api/vscode/ini/1.50.0/file/vscode.ini-1.50.0.vsix",
"vscode-builtin-jake": "https://open-vsx.org/api/vscode/jake/1.50.0/file/vscode.jake-1.50.0.vsix",
"vscode-builtin-java": "https://open-vsx.org/api/vscode/java/1.50.0/file/vscode.java-1.50.0.vsix",
@@ -47,9 +48,9 @@
"vscode-builtin-markdown": "https://open-vsx.org/api/vscode/markdown/1.50.0/file/vscode.markdown-1.50.0.vsix",
"vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.2/file/vscode.markdown-language-features-1.39.2.vsix",
"vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.50.0/file/vscode.merge-conflict-1.50.0.vsix",
+ "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.45.0/file/ms-vscode.node-debug-1.45.0.vsix",
+ "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.43.0/file/ms-vscode.node-debug2-1.43.0.vsix",
"vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.50.0/file/vscode.npm-1.50.0.vsix",
- "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.44.28/file/ms-vscode.node-debug-1.44.28.vsix",
- "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.42.7/file/ms-vscode.node-debug2-1.42.7.vsix",
"vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.50.0/file/vscode.objective-c-1.50.0.vsix",
"vscode-builtin-perl": "https://open-vsx.org/api/vscode/perl/1.50.0/file/vscode.perl-1.50.0.vsix",
"vscode-builtin-powershell": "https://open-vsx.org/api/vscode/powershell/1.50.0/file/vscode.powershell-1.50.0.vsix",
@@ -76,59 +77,58 @@
"vscode-builtin-typescript": "https://open-vsx.org/api/vscode/typescript/1.50.0/file/vscode.typescript-1.50.0.vsix",
"vscode-builtin-typescript-language-features": "https://open-vsx.org/api/vscode/typescript-language-features/1.50.0/file/vscode.typescript-language-features-1.50.0.vsix",
"vscode-builtin-vb": "https://open-vsx.org/api/vscode/vb/1.50.0/file/vscode.vb-1.50.0.vsix",
- "vscode-builtin-icon-theme-seti": "https://open-vsx.org/api/vscode/vscode-theme-seti/1.50.0/file/vscode.vscode-theme-seti-1.50.0.vsix",
"vscode-builtin-xml": "https://open-vsx.org/api/vscode/xml/1.50.0/file/vscode.xml-1.50.0.vsix",
"vscode-builtin-yaml": "https://open-vsx.org/api/vscode/yaml/1.50.0/file/vscode.yaml-1.50.0.vsix",
- "vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.16.5/file/EditorConfig.EditorConfig-0.16.5.vsix",
+ "vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.16.6/file/EditorConfig.EditorConfig-0.16.6.vsix",
"vscode-eslint": "https://open-vsx.org/api/dbaeumer/vscode-eslint/2.1.8/file/dbaeumer.vscode-eslint-2.1.8.vsix",
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.80/file/ms-vscode.references-view-0.0.80.vsix"
},
"dependencies": {
- "@theia/bulk-edit": "1.16.0",
- "@theia/callhierarchy": "1.16.0",
- "@theia/console": "1.16.0",
- "@theia/core": "1.16.0",
- "@theia/debug": "1.16.0",
- "@theia/editor": "1.16.0",
- "@theia/editor-preview": "1.16.0",
- "@theia/electron": "1.16.0",
- "@theia/external-terminal": "1.16.0",
- "@theia/file-search": "1.16.0",
- "@theia/filesystem": "1.16.0",
- "@theia/getting-started": "1.16.0",
- "@theia/git": "1.16.0",
- "@theia/keymaps": "1.16.0",
- "@theia/markers": "1.16.0",
- "@theia/messages": "1.16.0",
- "@theia/metrics": "1.16.0",
- "@theia/mini-browser": "1.16.0",
- "@theia/monaco": "1.16.0",
- "@theia/navigator": "1.16.0",
- "@theia/outline-view": "1.16.0",
- "@theia/output": "1.16.0",
- "@theia/plugin": "1.16.0",
- "@theia/plugin-dev": "1.16.0",
- "@theia/plugin-ext": "1.16.0",
- "@theia/plugin-ext-vscode": "1.16.0",
- "@theia/plugin-metrics": "1.16.0",
- "@theia/preferences": "1.16.0",
- "@theia/preview": "1.16.0",
- "@theia/process": "1.16.0",
- "@theia/property-view": "1.16.0",
- "@theia/scm": "1.16.0",
- "@theia/scm-extra": "1.16.0",
- "@theia/search-in-workspace": "1.16.0",
- "@theia/task": "1.16.0",
- "@theia/terminal": "1.16.0",
- "@theia/timeline": "1.16.0",
- "@theia/typehierarchy": "1.16.0",
- "@theia/userstorage": "1.16.0",
- "@theia/variable-resolver": "1.16.0",
- "@theia/vsx-registry": "1.16.0",
- "@theia/workspace": "1.16.0"
+ "@theia/bulk-edit": "1.17.2",
+ "@theia/callhierarchy": "1.17.2",
+ "@theia/console": "1.17.2",
+ "@theia/core": "1.17.2",
+ "@theia/debug": "1.17.2",
+ "@theia/editor": "1.17.2",
+ "@theia/editor-preview": "1.17.2",
+ "@theia/electron": "1.17.2",
+ "@theia/external-terminal": "1.17.2",
+ "@theia/file-search": "1.17.2",
+ "@theia/filesystem": "1.17.2",
+ "@theia/getting-started": "1.17.2",
+ "@theia/git": "1.17.2",
+ "@theia/keymaps": "1.17.2",
+ "@theia/markers": "1.17.2",
+ "@theia/messages": "1.17.2",
+ "@theia/metrics": "1.17.2",
+ "@theia/mini-browser": "1.17.2",
+ "@theia/monaco": "1.17.2",
+ "@theia/navigator": "1.17.2",
+ "@theia/outline-view": "1.17.2",
+ "@theia/output": "1.17.2",
+ "@theia/plugin": "1.17.2",
+ "@theia/plugin-dev": "1.17.2",
+ "@theia/plugin-ext": "1.17.2",
+ "@theia/plugin-ext-vscode": "1.17.2",
+ "@theia/plugin-metrics": "1.17.2",
+ "@theia/preferences": "1.17.2",
+ "@theia/preview": "1.17.2",
+ "@theia/process": "1.17.2",
+ "@theia/property-view": "1.17.2",
+ "@theia/scm": "1.17.2",
+ "@theia/scm-extra": "1.17.2",
+ "@theia/search-in-workspace": "1.17.2",
+ "@theia/task": "1.17.2",
+ "@theia/terminal": "1.17.2",
+ "@theia/timeline": "1.17.2",
+ "@theia/typehierarchy": "1.17.2",
+ "@theia/userstorage": "1.17.2",
+ "@theia/variable-resolver": "1.17.2",
+ "@theia/vsx-registry": "1.17.2",
+ "@theia/workspace": "1.17.2"
},
"devDependencies": {
- "@theia/cli": "1.16.0"
+ "@theia/cli": "1.17.2"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",