summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-08-30 14:31:45 +0200
committerBence Hornák2020-08-30 14:31:45 +0200
commit4911a6afc6ab1857b3f102b4126f89bb22835b46 (patch)
tree016029cfa99af09a3b91010f4a12f8685b5da5ce
parent8a33eaaf9343ec8cc9192de7a82d10710d85981b (diff)
downloadaur-4911a6afc6ab1857b3f102b4126f89bb22835b46.tar.gz
Version 1.5.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--package.json81
3 files changed, 50 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b161e23b097..1a054ca8e3b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.4.0
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://www.theia-ide.org/
arch = any
license = EPL2
@@ -11,7 +11,7 @@ pkgbase = theia-electron
makedepends = pkgconf
makedepends = python2
makedepends = node-gyp
- depends = nodejs>=10.11.0
+ depends = nodejs>=12.14.1
depends = nodejs<13
depends = nss
depends = gtk3
@@ -23,10 +23,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.4.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.4.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.5.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.5.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = 4afa80c7dbb0391e94b1bdefd28636ee
+ md5sums = 6db9b981f8543c90db7666449c258631
md5sums = 54b30057095cf131ec7296b0d0bd2046
md5sums = b316dead79fa33f45c8d689a1c940dab
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index cd136be26e48..cc348663be09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Bence Hornák <bence.hornak@gmail.com>
pkgname=theia-electron
-pkgver=1.4.0
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
pkgdesc="Cloud & Desktop IDE Platform"
license=('EPL2')
-depends=('nodejs>=10.11.0' 'nodejs<13' 'nss' 'gtk3' 'libxss' 'libxkbfile')
+depends=('nodejs>=12.14.1' 'nodejs<13' 'nss' 'gtk3' 'libxss' 'libxkbfile')
makedepends=('yarn' 'make' 'gcc' 'pkgconf' 'python2' 'node-gyp')
optdepends=('git: git support')
options=(!strip) #to speed up build
@@ -21,7 +21,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- '4afa80c7dbb0391e94b1bdefd28636ee'
+ '6db9b981f8543c90db7666449c258631'
'54b30057095cf131ec7296b0d0bd2046'
'b316dead79fa33f45c8d689a1c940dab'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 5413fd829be3..c712f6ce4819 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.4.0",
+ "version": "1.5.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -83,48 +83,47 @@
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.47/file/ms-vscode.references-view-0.0.47.vsix"
},
"dependencies": {
- "@theia/callhierarchy": "1.4.0",
- "@theia/console": "1.4.0",
- "@theia/core": "1.4.0",
- "@theia/debug": "1.4.0",
- "@theia/editor": "1.4.0",
- "@theia/editor-preview": "1.4.0",
- "@theia/electron": "1.4.0",
- "@theia/file-search": "1.4.0",
- "@theia/filesystem": "1.4.0",
- "@theia/getting-started": "1.4.0",
- "@theia/git": "1.4.0",
- "@theia/keymaps": "1.4.0",
- "@theia/languages": "1.4.0",
- "@theia/markers": "1.4.0",
- "@theia/messages": "1.4.0",
- "@theia/metrics": "1.4.0",
- "@theia/mini-browser": "1.4.0",
- "@theia/monaco": "1.4.0",
- "@theia/navigator": "1.4.0",
- "@theia/outline-view": "1.4.0",
- "@theia/output": "1.4.0",
- "@theia/plugin": "1.4.0",
- "@theia/plugin-dev": "1.4.0",
- "@theia/plugin-ext": "1.4.0",
- "@theia/plugin-ext-vscode": "1.4.0",
- "@theia/plugin-metrics": "1.4.0",
- "@theia/preferences": "1.4.0",
- "@theia/preview": "1.4.0",
- "@theia/process": "1.4.0",
- "@theia/scm": "1.4.0",
- "@theia/scm-extra": "1.4.0",
- "@theia/search-in-workspace": "1.4.0",
- "@theia/task": "1.4.0",
- "@theia/terminal": "1.4.0",
- "@theia/typehierarchy": "1.4.0",
- "@theia/userstorage": "1.4.0",
- "@theia/variable-resolver": "1.4.0",
- "@theia/vsx-registry": "1.4.0",
- "@theia/workspace": "1.4.0"
+ "@theia/callhierarchy": "1.5.0",
+ "@theia/console": "1.5.0",
+ "@theia/core": "1.5.0",
+ "@theia/debug": "1.5.0",
+ "@theia/editor": "1.5.0",
+ "@theia/editor-preview": "1.5.0",
+ "@theia/electron": "1.5.0",
+ "@theia/file-search": "1.5.0",
+ "@theia/filesystem": "1.5.0",
+ "@theia/getting-started": "1.5.0",
+ "@theia/git": "1.5.0",
+ "@theia/keymaps": "1.5.0",
+ "@theia/markers": "1.5.0",
+ "@theia/messages": "1.5.0",
+ "@theia/metrics": "1.5.0",
+ "@theia/mini-browser": "1.5.0",
+ "@theia/monaco": "1.5.0",
+ "@theia/navigator": "1.5.0",
+ "@theia/outline-view": "1.5.0",
+ "@theia/output": "1.5.0",
+ "@theia/plugin": "1.5.0",
+ "@theia/plugin-dev": "1.5.0",
+ "@theia/plugin-ext": "1.5.0",
+ "@theia/plugin-ext-vscode": "1.5.0",
+ "@theia/plugin-metrics": "1.5.0",
+ "@theia/preferences": "1.5.0",
+ "@theia/preview": "1.5.0",
+ "@theia/process": "1.5.0",
+ "@theia/scm": "1.5.0",
+ "@theia/scm-extra": "1.5.0",
+ "@theia/search-in-workspace": "1.5.0",
+ "@theia/task": "1.5.0",
+ "@theia/terminal": "1.5.0",
+ "@theia/typehierarchy": "1.5.0",
+ "@theia/userstorage": "1.5.0",
+ "@theia/variable-resolver": "1.5.0",
+ "@theia/vsx-registry": "1.5.0",
+ "@theia/workspace": "1.5.0"
},
"devDependencies": {
- "@theia/cli": "1.4.0"
+ "@theia/cli": "1.5.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",