summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon De Andrade2021-06-27 13:01:51 +0000
committerLeon De Andrade2021-06-27 13:01:51 +0000
commit7c25bd0b4c459dd2da81b355b84aeb373fcf3eac (patch)
tree9970f7bad189baa875d8da596484d8510c0a5fe3
parent340e4bbbd29ab760ad905dc65fe0287ede3dd859 (diff)
downloadaur-7c25bd0b4c459dd2da81b355b84aeb373fcf3eac.tar.gz
Upgrade to upstream 1.14.0.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD4
-rw-r--r--package.json90
3 files changed, 51 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8eb16016e657..fd032ab62baf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.12.0
+ pkgver = 1.14.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -22,14 +22,13 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.12.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.12.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.14.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.14.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = 9b7fba5b86132481366ccc002d27c6ba
+ md5sums = b167f5bf37cad01957c0720ab4dc2a79
md5sums = 8a3461a9d1c50f6bfe60902d020bb797
md5sums = d387a0df41b11ba3d33360812bfbbe2c
md5sums = 1dde0e422484895d3509f4ee9bb8d980
md5sums = 84e52389f141be88a24bcfdd44c91a19
pkgname = theia-electron
-
diff --git a/PKGBUILD b/PKGBUILD
index 85513761d74d..79ee24b0dea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leon De Andrade <leondeandrade@hotmail.com>
pkgname=theia-electron
-pkgver=1.12.0
+pkgver=1.14.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -22,7 +22,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- '7565a886e82b5aa123ef3587e030ed84'
+ 'b167f5bf37cad01957c0720ab4dc2a79'
'8a3461a9d1c50f6bfe60902d020bb797'
'd387a0df41b11ba3d33360812bfbbe2c'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 758e66e9f68d..31333f109a11 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.12.0",
+ "version": "1.14.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -81,54 +81,54 @@
"vscode-builtin-yaml": "https://open-vsx.org/api/vscode/yaml/1.50.0/file/vscode.yaml-1.50.0.vsix",
"vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.15.1/file/EditorConfig.EditorConfig-0.15.1.vsix",
"vscode-eslint": "https://open-vsx.org/api/dbaeumer/vscode-eslint/2.1.8/file/dbaeumer.vscode-eslint-2.1.8.vsix",
- "vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.75/file/ms-vscode.references-view-0.0.75.vsix"
+ "vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.80/file/ms-vscode.references-view-0.0.80.vsix"
},
"dependencies": {
- "@theia/bulk-edit": "1.12.0",
- "@theia/callhierarchy": "1.12.0",
- "@theia/console": "1.12.0",
- "@theia/core": "1.12.0",
- "@theia/debug": "1.12.0",
- "@theia/editor-preview": "1.12.0",
- "@theia/editor": "1.12.0",
- "@theia/electron": "1.12.0",
- "@theia/external-terminal": "1.12.0",
- "@theia/file-search": "1.12.0",
- "@theia/filesystem": "1.12.0",
- "@theia/getting-started": "1.12.0",
- "@theia/git": "1.12.0",
- "@theia/keymaps": "1.12.0",
- "@theia/markers": "1.12.0",
- "@theia/messages": "1.12.0",
- "@theia/metrics": "1.12.0",
- "@theia/mini-browser": "1.12.0",
- "@theia/monaco": "1.12.0",
- "@theia/navigator": "1.12.0",
- "@theia/outline-view": "1.12.0",
- "@theia/output": "1.12.0",
- "@theia/plugin-dev": "1.12.0",
- "@theia/plugin-ext-vscode": "1.12.0",
- "@theia/plugin-ext": "1.12.0",
- "@theia/plugin-metrics": "1.12.0",
- "@theia/plugin": "1.12.0",
- "@theia/preferences": "1.12.0",
- "@theia/preview": "1.12.0",
- "@theia/process": "1.12.0",
- "@theia/property-view": "1.12.0",
- "@theia/scm-extra": "1.12.0",
- "@theia/scm": "1.12.0",
- "@theia/search-in-workspace": "1.12.0",
- "@theia/task": "1.12.0",
- "@theia/terminal": "1.12.0",
- "@theia/timeline": "1.12.0",
- "@theia/typehierarchy": "1.12.0",
- "@theia/userstorage": "1.12.0",
- "@theia/variable-resolver": "1.12.0",
- "@theia/vsx-registry": "1.12.0",
- "@theia/workspace": "1.12.0"
+ "@theia/bulk-edit": "1.14.0",
+ "@theia/callhierarchy": "1.14.0",
+ "@theia/console": "1.14.0",
+ "@theia/core": "1.14.0",
+ "@theia/debug": "1.14.0",
+ "@theia/editor": "1.14.0",
+ "@theia/editor-preview": "1.14.0",
+ "@theia/electron": "1.14.0",
+ "@theia/external-terminal": "1.14.0",
+ "@theia/file-search": "1.14.0",
+ "@theia/filesystem": "1.14.0",
+ "@theia/getting-started": "1.14.0",
+ "@theia/git": "1.14.0",
+ "@theia/keymaps": "1.14.0",
+ "@theia/markers": "1.14.0",
+ "@theia/messages": "1.14.0",
+ "@theia/metrics": "1.14.0",
+ "@theia/mini-browser": "1.14.0",
+ "@theia/monaco": "1.14.0",
+ "@theia/navigator": "1.14.0",
+ "@theia/outline-view": "1.14.0",
+ "@theia/output": "1.14.0",
+ "@theia/plugin": "1.14.0",
+ "@theia/plugin-dev": "1.14.0",
+ "@theia/plugin-ext": "1.14.0",
+ "@theia/plugin-ext-vscode": "1.14.0",
+ "@theia/plugin-metrics": "1.14.0",
+ "@theia/preferences": "1.14.0",
+ "@theia/preview": "1.14.0",
+ "@theia/process": "1.14.0",
+ "@theia/property-view": "1.14.0",
+ "@theia/scm": "1.14.0",
+ "@theia/scm-extra": "1.14.0",
+ "@theia/search-in-workspace": "1.14.0",
+ "@theia/task": "1.14.0",
+ "@theia/terminal": "1.14.0",
+ "@theia/timeline": "1.14.0",
+ "@theia/typehierarchy": "1.14.0",
+ "@theia/userstorage": "1.14.0",
+ "@theia/variable-resolver": "1.14.0",
+ "@theia/vsx-registry": "1.14.0",
+ "@theia/workspace": "1.14.0"
},
"devDependencies": {
- "@theia/cli": "1.12.0"
+ "@theia/cli": "1.14.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",