summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2021-08-08 15:21:13 +0000
committerBence Hornák2021-08-08 15:21:13 +0000
commit830137bf389abc23e6adb5670469e61068947020 (patch)
tree3b74a88f6ea316e29da026b62bea4a6ed1972b29
parentcd76cc1f1aef521c357d7aaef4b13ea7fdfa242e (diff)
parent0c985f1bb2d5ed004dc30dd8821bee9611b9dd0d (diff)
downloadaur-830137bf389abc23e6adb5670469e61068947020.tar.gz
Merge branch 'release/v1.16.0' into 'master'
Upgrade to v1.16.0. See merge request bencehornak/arch-theia-electron!10
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
-rw-r--r--package.json96
3 files changed, 56 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f929d1f30a0..7d39b3db0fc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.14.0
+ pkgver = 1.16.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -17,15 +17,16 @@ pkgbase = theia-electron
depends = libxss
depends = libxkbfile
optdepends = git: git support
+ optdepends = libsecret: keytar support
options = !strip
source = theia-electron.sh
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.14.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.14.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.16.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.16.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = aca0c5da32944e7a9dd519304a362bc6
+ md5sums = 644ba3afe6ad93ad91afd9eabb461f04
md5sums = 8a3461a9d1c50f6bfe60902d020bb797
md5sums = d387a0df41b11ba3d33360812bfbbe2c
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index fc0f1c1c3df9..f9565be306fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leon De Andrade <leondeandrade@hotmail.com>
pkgname=theia-electron
-pkgver=1.14.0
+pkgver=1.16.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -10,7 +10,7 @@ pkgdesc="Cloud & Desktop IDE Platform"
license=('EPL2')
depends=('nodejs-lts-erbium' 'nss' 'gtk3' 'libxss' 'libxkbfile')
makedepends=('yarn' 'make' 'gcc' 'pkgconf' 'python2' 'node-gyp')
-optdepends=('git: git support')
+optdepends=('git: git support' 'libsecret: keytar support')
options=(!strip) #to speed up build
source=(
@@ -22,7 +22,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- 'aca0c5da32944e7a9dd519304a362bc6'
+ '644ba3afe6ad93ad91afd9eabb461f04'
'8a3461a9d1c50f6bfe60902d020bb797'
'd387a0df41b11ba3d33360812bfbbe2c'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 31333f109a11..7df8f88fc854 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.14.0",
+ "version": "1.16.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -48,8 +48,8 @@
"vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.2/file/vscode.markdown-language-features-1.39.2.vsix",
"vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.50.0/file/vscode.merge-conflict-1.50.0.vsix",
"vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.50.0/file/vscode.npm-1.50.0.vsix",
- "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.44.8/file/ms-vscode.node-debug-1.44.8.vsix",
- "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.42.5/file/ms-vscode.node-debug2-1.42.5.vsix",
+ "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.44.28/file/ms-vscode.node-debug-1.44.28.vsix",
+ "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.42.7/file/ms-vscode.node-debug2-1.42.7.vsix",
"vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.50.0/file/vscode.objective-c-1.50.0.vsix",
"vscode-builtin-perl": "https://open-vsx.org/api/vscode/perl/1.50.0/file/vscode.perl-1.50.0.vsix",
"vscode-builtin-powershell": "https://open-vsx.org/api/vscode/powershell/1.50.0/file/vscode.powershell-1.50.0.vsix",
@@ -79,59 +79,59 @@
"vscode-builtin-icon-theme-seti": "https://open-vsx.org/api/vscode/vscode-theme-seti/1.50.0/file/vscode.vscode-theme-seti-1.50.0.vsix",
"vscode-builtin-xml": "https://open-vsx.org/api/vscode/xml/1.50.0/file/vscode.xml-1.50.0.vsix",
"vscode-builtin-yaml": "https://open-vsx.org/api/vscode/yaml/1.50.0/file/vscode.yaml-1.50.0.vsix",
- "vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.15.1/file/EditorConfig.EditorConfig-0.15.1.vsix",
+ "vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.16.5/file/EditorConfig.EditorConfig-0.16.5.vsix",
"vscode-eslint": "https://open-vsx.org/api/dbaeumer/vscode-eslint/2.1.8/file/dbaeumer.vscode-eslint-2.1.8.vsix",
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.80/file/ms-vscode.references-view-0.0.80.vsix"
},
"dependencies": {
- "@theia/bulk-edit": "1.14.0",
- "@theia/callhierarchy": "1.14.0",
- "@theia/console": "1.14.0",
- "@theia/core": "1.14.0",
- "@theia/debug": "1.14.0",
- "@theia/editor": "1.14.0",
- "@theia/editor-preview": "1.14.0",
- "@theia/electron": "1.14.0",
- "@theia/external-terminal": "1.14.0",
- "@theia/file-search": "1.14.0",
- "@theia/filesystem": "1.14.0",
- "@theia/getting-started": "1.14.0",
- "@theia/git": "1.14.0",
- "@theia/keymaps": "1.14.0",
- "@theia/markers": "1.14.0",
- "@theia/messages": "1.14.0",
- "@theia/metrics": "1.14.0",
- "@theia/mini-browser": "1.14.0",
- "@theia/monaco": "1.14.0",
- "@theia/navigator": "1.14.0",
- "@theia/outline-view": "1.14.0",
- "@theia/output": "1.14.0",
- "@theia/plugin": "1.14.0",
- "@theia/plugin-dev": "1.14.0",
- "@theia/plugin-ext": "1.14.0",
- "@theia/plugin-ext-vscode": "1.14.0",
- "@theia/plugin-metrics": "1.14.0",
- "@theia/preferences": "1.14.0",
- "@theia/preview": "1.14.0",
- "@theia/process": "1.14.0",
- "@theia/property-view": "1.14.0",
- "@theia/scm": "1.14.0",
- "@theia/scm-extra": "1.14.0",
- "@theia/search-in-workspace": "1.14.0",
- "@theia/task": "1.14.0",
- "@theia/terminal": "1.14.0",
- "@theia/timeline": "1.14.0",
- "@theia/typehierarchy": "1.14.0",
- "@theia/userstorage": "1.14.0",
- "@theia/variable-resolver": "1.14.0",
- "@theia/vsx-registry": "1.14.0",
- "@theia/workspace": "1.14.0"
+ "@theia/bulk-edit": "1.16.0",
+ "@theia/callhierarchy": "1.16.0",
+ "@theia/console": "1.16.0",
+ "@theia/core": "1.16.0",
+ "@theia/debug": "1.16.0",
+ "@theia/editor": "1.16.0",
+ "@theia/editor-preview": "1.16.0",
+ "@theia/electron": "1.16.0",
+ "@theia/external-terminal": "1.16.0",
+ "@theia/file-search": "1.16.0",
+ "@theia/filesystem": "1.16.0",
+ "@theia/getting-started": "1.16.0",
+ "@theia/git": "1.16.0",
+ "@theia/keymaps": "1.16.0",
+ "@theia/markers": "1.16.0",
+ "@theia/messages": "1.16.0",
+ "@theia/metrics": "1.16.0",
+ "@theia/mini-browser": "1.16.0",
+ "@theia/monaco": "1.16.0",
+ "@theia/navigator": "1.16.0",
+ "@theia/outline-view": "1.16.0",
+ "@theia/output": "1.16.0",
+ "@theia/plugin": "1.16.0",
+ "@theia/plugin-dev": "1.16.0",
+ "@theia/plugin-ext": "1.16.0",
+ "@theia/plugin-ext-vscode": "1.16.0",
+ "@theia/plugin-metrics": "1.16.0",
+ "@theia/preferences": "1.16.0",
+ "@theia/preview": "1.16.0",
+ "@theia/process": "1.16.0",
+ "@theia/property-view": "1.16.0",
+ "@theia/scm": "1.16.0",
+ "@theia/scm-extra": "1.16.0",
+ "@theia/search-in-workspace": "1.16.0",
+ "@theia/task": "1.16.0",
+ "@theia/terminal": "1.16.0",
+ "@theia/timeline": "1.16.0",
+ "@theia/typehierarchy": "1.16.0",
+ "@theia/userstorage": "1.16.0",
+ "@theia/variable-resolver": "1.16.0",
+ "@theia/vsx-registry": "1.16.0",
+ "@theia/workspace": "1.16.0"
},
"devDependencies": {
- "@theia/cli": "1.14.0"
+ "@theia/cli": "1.16.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",
"start": "theia start"
}
-} \ No newline at end of file
+}