summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-10-11 11:16:05 +0000
committerBence Hornák2020-10-11 11:16:05 +0000
commitad99bb8c718b578d7a945e1f640c66bdfdc398e4 (patch)
treeade9a74cce7fa463f3e0fa8f1f42df138105dd54
parent21a42f04f1bcdfab1882c38d7e002a6002492c6b (diff)
downloadaur-ad99bb8c718b578d7a945e1f640c66bdfdc398e4.tar.gz
Fix issue #1 (package.json symlink)
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 599ff375f0f7..e76312698dba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,10 +42,13 @@ package() {
# Source code (symlinks are not dereferenced) and plugins
cp -r --no-preserve=ownership --preserve=mode \
- src-gen lib node_modules package.json \
+ src-gen lib node_modules \
plugins \
"$pkgdir/usr/lib/$pkgname/"
+ # package.json
+ install -Dm755 package.json "$pkgdir/usr/lib/$pkgname/"
+
# Executable
install -Dm755 theia-electron.sh "$pkgdir/usr/bin/$pkgname"
# Desktop file