summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon De Andrade2020-12-17 15:58:23 +0100
committerLeon De Andrade2020-12-17 15:58:23 +0100
commitb6749534c4afc77a25f3e1ff8dab785d0afd206f (patch)
tree61c6add25868e18888692a469fcdeb1fef102835
parentbabfed4b54a2f54a585e95beb92377bae12db9ab (diff)
downloadaur-b6749534c4afc77a25f3e1ff8dab785d0afd206f.tar.gz
Update to 1.9.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
-rw-r--r--package.json84
3 files changed, 50 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddeafdd3a2ae..2362d48c98fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.8.0
+ pkgver = 1.9.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -11,8 +11,7 @@ pkgbase = theia-electron
makedepends = pkgconf
makedepends = python2
makedepends = node-gyp
- depends = nodejs>=12.14.1
- depends = nodejs<13
+ depends = nodejs-lts-erbium
depends = nss
depends = gtk3
depends = libxss
@@ -23,10 +22,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.8.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.8.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.9.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.9.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = bdf11868c91a8d9a0a7e81ca0366e350
+ md5sums = c308320e66044089fc2ce2301f817b4e
md5sums = 8a3461a9d1c50f6bfe60902d020bb797
md5sums = d387a0df41b11ba3d33360812bfbbe2c
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index 38cb153e4bbc..4781af5861af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Leon De Andrade <leondeandrade@hotmail.com>
pkgname=theia-electron
-pkgver=1.8.0
+pkgver=1.9.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
pkgdesc="Cloud & Desktop IDE Platform"
license=('EPL2')
-depends=('nodejs>=12.14.1' 'nodejs<13' 'nss' 'gtk3' 'libxss' 'libxkbfile')
+depends=('nodejs-lts-erbium' 'nss' 'gtk3' 'libxss' 'libxkbfile')
makedepends=('yarn' 'make' 'gcc' 'pkgconf' 'python2' 'node-gyp')
optdepends=('git: git support')
options=(!strip) #to speed up build
@@ -22,7 +22,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- 'bdf11868c91a8d9a0a7e81ca0366e350'
+ 'c308320e66044089fc2ce2301f817b4e'
'8a3461a9d1c50f6bfe60902d020bb797'
'd387a0df41b11ba3d33360812bfbbe2c'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index e12a57bc0e76..0e6b60136740 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.8.0",
+ "version": "1.9.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -81,51 +81,51 @@
"vscode-builtin-yaml": "https://open-vsx.org/api/vscode/yaml/1.50.0/file/vscode.yaml-1.50.0.vsix",
"vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.15.1/file/EditorConfig.EditorConfig-0.15.1.vsix",
"vscode-eslint": "https://open-vsx.org/api/dbaeumer/vscode-eslint/2.1.8/file/dbaeumer.vscode-eslint-2.1.8.vsix",
- "vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.73/file/ms-vscode.references-view-0.0.73.vsix"
+ "vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.75/file/ms-vscode.references-view-0.0.75.vsix"
},
"dependencies": {
- "@theia/callhierarchy": "1.8.0",
- "@theia/console": "1.8.0",
- "@theia/core": "1.8.0",
- "@theia/debug": "1.8.0",
- "@theia/editor-preview": "1.8.0",
- "@theia/editor": "1.8.0",
- "@theia/electron": "1.8.0",
- "@theia/file-search": "1.8.0",
- "@theia/filesystem": "1.8.0",
- "@theia/getting-started": "1.8.0",
- "@theia/git": "1.8.0",
- "@theia/keymaps": "1.8.0",
- "@theia/markers": "1.8.0",
- "@theia/messages": "1.8.0",
- "@theia/metrics": "1.8.0",
- "@theia/mini-browser": "1.8.0",
- "@theia/monaco": "1.8.0",
- "@theia/navigator": "1.8.0",
- "@theia/outline-view": "1.8.0",
- "@theia/output": "1.8.0",
- "@theia/plugin-dev": "1.8.0",
- "@theia/plugin-ext-vscode": "1.8.0",
- "@theia/plugin-ext": "1.8.0",
- "@theia/plugin-metrics": "1.8.0",
- "@theia/plugin": "1.8.0",
- "@theia/preferences": "1.8.0",
- "@theia/preview": "1.8.0",
- "@theia/process": "1.8.0",
- "@theia/scm-extra": "1.8.0",
- "@theia/scm": "1.8.0",
- "@theia/search-in-workspace": "1.8.0",
- "@theia/task": "1.8.0",
- "@theia/terminal": "1.8.0",
- "@theia/timeline": "1.8.0",
- "@theia/typehierarchy": "1.8.0",
- "@theia/userstorage": "1.8.0",
- "@theia/variable-resolver": "1.8.0",
- "@theia/vsx-registry": "1.8.0",
- "@theia/workspace": "1.8.0"
+ "@theia/callhierarchy": "1.9.0",
+ "@theia/console": "1.9.0",
+ "@theia/core": "1.9.0",
+ "@theia/debug": "1.9.0",
+ "@theia/editor-preview": "1.9.0",
+ "@theia/editor": "1.9.0",
+ "@theia/electron": "1.9.0",
+ "@theia/file-search": "1.9.0",
+ "@theia/filesystem": "1.9.0",
+ "@theia/getting-started": "1.9.0",
+ "@theia/git": "1.9.0",
+ "@theia/keymaps": "1.9.0",
+ "@theia/markers": "1.9.0",
+ "@theia/messages": "1.9.0",
+ "@theia/metrics": "1.9.0",
+ "@theia/mini-browser": "1.9.0",
+ "@theia/monaco": "1.9.0",
+ "@theia/navigator": "1.9.0",
+ "@theia/outline-view": "1.9.0",
+ "@theia/output": "1.9.0",
+ "@theia/plugin-dev": "1.9.0",
+ "@theia/plugin-ext-vscode": "1.9.0",
+ "@theia/plugin-ext": "1.9.0",
+ "@theia/plugin-metrics": "1.9.0",
+ "@theia/plugin": "1.9.0",
+ "@theia/preferences": "1.9.0",
+ "@theia/preview": "1.9.0",
+ "@theia/process": "1.9.0",
+ "@theia/scm-extra": "1.9.0",
+ "@theia/scm": "1.9.0",
+ "@theia/search-in-workspace": "1.9.0",
+ "@theia/task": "1.9.0",
+ "@theia/terminal": "1.9.0",
+ "@theia/timeline": "1.9.0",
+ "@theia/typehierarchy": "1.9.0",
+ "@theia/userstorage": "1.9.0",
+ "@theia/variable-resolver": "1.9.0",
+ "@theia/vsx-registry": "1.9.0",
+ "@theia/workspace": "1.9.0"
},
"devDependencies": {
- "@theia/cli": "1.8.0"
+ "@theia/cli": "1.9.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",