summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-06-25 20:03:59 +0200
committerBence Hornák2020-06-25 20:03:59 +0200
commitba67eb571560566166e9cf1627dcd3a5bf73d851 (patch)
tree6bae2746457c484665370166d0490808eafcc075
parentbb3ba09e97a59f8d2eea6fa9c77816131d6e5539 (diff)
downloadaur-ba67eb571560566166e9cf1627dcd3a5bf73d851.tar.gz
Version 1.3.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--package.json84
3 files changed, 49 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae10261f1882..3d5ea5691168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.2.0
+ pkgver = 1.3.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -22,10 +22,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.2.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.2.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.3.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.3.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = d254be29e8f55f78d8f8d5d4801403d8
+ md5sums = bba497da728fc3794e8382a095d07469
md5sums = 54b30057095cf131ec7296b0d0bd2046
md5sums = b316dead79fa33f45c8d689a1c940dab
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index e6f409ec7497..7f9f64d02d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bence Hornák <bence.hornak@gmail.com>
pkgname=theia-electron
-pkgver=1.2.0
+pkgver=1.3.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -21,7 +21,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- 'd254be29e8f55f78d8f8d5d4801403d8'
+ 'bba497da728fc3794e8382a095d07469'
'54b30057095cf131ec7296b0d0bd2046'
'b316dead79fa33f45c8d689a1c940dab'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 92c5dbde4085..d09853548055 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.2.0",
+ "version": "1.3.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -20,6 +20,7 @@
"vscode-builtin-cpp": "https://open-vsx.org/api/vscode/cpp/1.44.2/file/vscode.cpp-1.44.2.vsix",
"vscode-builtin-csharp": "https://open-vsx.org/api/vscode/csharp/1.44.2/file/vscode.csharp-1.44.2.vsix",
"vscode-builtin-css": "https://open-vsx.org/api/vscode/css/1.44.2/file/vscode.css-1.44.2.vsix",
+ "vscode-builtin-css-language-features": "https://open-vsx.org/api/vscode/css-language-features/1.45.1/file/vscode.css-language-features-1.45.1.vsix",
"vscode-builtin-debug-auto-launch": "https://open-vsx.org/api/vscode/debug-auto-launch/1.44.2/file/vscode.debug-auto-launch-1.44.2.vsix",
"vscode-builtin-docker": "https://open-vsx.org/api/vscode/docker/1.44.2/file/vscode.docker-1.44.2.vsix",
"vscode-builtin-emmet": "https://open-vsx.org/api/vscode/emmet/1.44.2/file/vscode.emmet-1.44.2.vsix",
@@ -31,6 +32,7 @@
"vscode-builtin-handlebars": "https://open-vsx.org/api/vscode/handlebars/1.44.2/file/vscode.handlebars-1.44.2.vsix",
"vscode-builtin-hlsl": "https://open-vsx.org/api/vscode/hlsl/1.44.2/file/vscode.hlsl-1.44.2.vsix",
"vscode-builtin-html": "https://open-vsx.org/api/vscode/html/1.44.2/file/vscode.html-1.44.2.vsix",
+ "vscode-builtin-html-language-features": "https://open-vsx.org/api/vscode/html-language-features/1.45.1/file/vscode.html-language-features-1.45.1.vsix",
"vscode-builtin-ini": "https://open-vsx.org/api/vscode/ini/1.44.2/file/vscode.ini-1.44.2.vsix",
"vscode-builtin-jake": "https://open-vsx.org/api/vscode/jake/1.44.2/file/vscode.jake-1.44.2.vsix",
"vscode-builtin-java": "https://open-vsx.org/api/vscode/java/1.44.2/file/vscode.java-1.44.2.vsix",
@@ -43,7 +45,7 @@
"vscode-builtin-markdown": "https://open-vsx.org/api/vscode/markdown/1.44.2/file/vscode.markdown-1.44.2.vsix",
"vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.1/file/vscode.markdown-language-features-1.39.1.vsix",
"vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.44.2/file/vscode.merge-conflict-1.44.2.vsix",
- "vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.39.1/file/vscode.npm-1.39.1.vsix",
+ "vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.44.2/file/vscode.npm-1.44.2.vsix",
"vscode-builtin-node-debug": "https://github.com/theia-ide/vscode-node-debug/releases/download/v1.35.3/node-debug-1.35.3.vsix",
"vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.33.0/file/ms-vscode.node-debug2-1.33.0.vsix",
"vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.44.2/file/vscode.objective-c-1.44.2.vsix",
@@ -80,47 +82,47 @@
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.47/file/ms-vscode.references-view-0.0.47.vsix"
},
"dependencies": {
- "@theia/callhierarchy": "1.2.0",
- "@theia/console": "1.2.0",
- "@theia/core": "1.2.0",
- "@theia/debug": "1.2.0",
- "@theia/editor": "1.2.0",
- "@theia/editor-preview": "1.2.0",
- "@theia/electron": "1.2.0",
- "@theia/file-search": "1.2.0",
- "@theia/filesystem": "1.2.0",
- "@theia/getting-started": "1.2.0",
- "@theia/git": "1.2.0",
- "@theia/json": "1.2.0",
- "@theia/keymaps": "1.2.0",
- "@theia/languages": "1.2.0",
- "@theia/markers": "1.2.0",
- "@theia/messages": "1.2.0",
- "@theia/metrics": "1.2.0",
- "@theia/mini-browser": "1.2.0",
- "@theia/monaco": "1.2.0",
- "@theia/navigator": "1.2.0",
- "@theia/outline-view": "1.2.0",
- "@theia/output": "1.2.0",
- "@theia/plugin-dev": "1.2.0",
- "@theia/plugin-ext": "1.2.0",
- "@theia/plugin-ext-vscode": "1.2.0",
- "@theia/preferences": "1.2.0",
- "@theia/preview": "1.2.0",
- "@theia/process": "1.2.0",
- "@theia/scm": "1.2.0",
- "@theia/scm-extra": "1.2.0",
- "@theia/search-in-workspace": "1.2.0",
- "@theia/task": "1.2.0",
- "@theia/terminal": "1.2.0",
- "@theia/typehierarchy": "1.2.0",
- "@theia/userstorage": "1.2.0",
- "@theia/variable-resolver": "1.2.0",
- "@theia/vsx-registry": "1.2.0",
- "@theia/workspace": "1.2.0"
+ "@theia/callhierarchy": "1.3.0",
+ "@theia/console": "1.3.0",
+ "@theia/core": "1.3.0",
+ "@theia/debug": "1.3.0",
+ "@theia/editor": "1.3.0",
+ "@theia/editor-preview": "1.3.0",
+ "@theia/electron": "1.3.0",
+ "@theia/file-search": "1.3.0",
+ "@theia/filesystem": "1.3.0",
+ "@theia/getting-started": "1.3.0",
+ "@theia/git": "1.3.0",
+ "@theia/json": "1.3.0",
+ "@theia/keymaps": "1.3.0",
+ "@theia/languages": "1.3.0",
+ "@theia/markers": "1.3.0",
+ "@theia/messages": "1.3.0",
+ "@theia/metrics": "1.3.0",
+ "@theia/mini-browser": "1.3.0",
+ "@theia/monaco": "1.3.0",
+ "@theia/navigator": "1.3.0",
+ "@theia/outline-view": "1.3.0",
+ "@theia/output": "1.3.0",
+ "@theia/plugin-dev": "1.3.0",
+ "@theia/plugin-ext": "1.3.0",
+ "@theia/plugin-ext-vscode": "1.3.0",
+ "@theia/preferences": "1.3.0",
+ "@theia/preview": "1.3.0",
+ "@theia/process": "1.3.0",
+ "@theia/scm": "1.3.0",
+ "@theia/scm-extra": "1.3.0",
+ "@theia/search-in-workspace": "1.3.0",
+ "@theia/task": "1.3.0",
+ "@theia/terminal": "1.3.0",
+ "@theia/typehierarchy": "1.3.0",
+ "@theia/userstorage": "1.3.0",
+ "@theia/variable-resolver": "1.3.0",
+ "@theia/vsx-registry": "1.3.0",
+ "@theia/workspace": "1.3.0"
},
"devDependencies": {
- "@theia/cli": "1.2.0"
+ "@theia/cli": "1.3.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",